summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2019-12-17 06:39:09 +0100
committerAkim Demaille <akim.demaille@gmail.com>2019-12-31 12:00:02 +0100
commit78bb152a63f711af65364881c434af4c198e1ee0 (patch)
treea842e2138f85aa76c86055eaf43324b68466040e /configure.ac
parent4d6ff4c5e5869772e98a324e05374a5e0a232302 (diff)
downloadbison-78bb152a63f711af65364881c434af4c198e1ee0.tar.gz
tests: also check -Wchar-subscripts
GCC's -Wchar-subscripts may report issues on platforms where char is unsigned. Unfortunately the current CI does not reproduce the problem. But that would allow contributors to report issues if the warning appears somewhere. See 139d0655947c87f90af08718618feaaca0e558d7. Problem reported by Andy Fiddaman in: https://lists.gnu.org/r/bug-bison/2019-12/msg00021.html * configure.ac (warn_common): Add -Wchar-subscripts.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7a80eac1..240ca3d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,7 +100,8 @@ if test "$enable_gcc_warnings" = yes; then
# -Wno-tautological-constant-out-of-range-compare for Clang 3.3 and
# 3.4 on GNU/Linux that choke on intprops.h's INT_MULTIPLY_WRAPV,
# etc.
- warn_common='-Wall -Wextra -Wcast-align
+ warn_common='-Wall -Wextra
+ -Wcast-align -Wchar-subscripts
-fparse-all-comments -Wdocumentation
-Wformat -Wimplicit-fallthrough -Wnull-dereference
-Wno-sign-compare -Wno-tautological-constant-out-of-range-compare