summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2020-01-16 06:29:25 +0100
committerAkim Demaille <akim.demaille@gmail.com>2020-01-19 11:36:47 +0100
commit61b8a8def5cafd3d6b70d4f5f8d14d067e8ac971 (patch)
tree25e59f33e8deb6eacd7c946a78fbefe6d54cdeb1 /configure.ac
parent6990c5bde968ca756fb817ff8243d787ef9b35c3 (diff)
downloadbison-61b8a8def5cafd3d6b70d4f5f8d14d067e8ac971.tar.gz
CI: use ICC again
See https://github.com/nemequ/icc-travis/issues/15. Thanks to Jeff Hammond and Evan Nemerson for their help. * configure.ac (warn_common): Disable dubious warnings. * .travis.yml: Use ICC again.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 29 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3f144cbc..68c54a12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,13 +102,41 @@ if test "$enable_gcc_warnings" = yes; then
# -Wno-tautological-constant-out-of-range-compare for Clang 3.3 and
# 3.4 on GNU/Linux that choke on intprops.h's INT_MULTIPLY_WRAPV,
# etc.
+ #
+ # ICC: -wr188
+ #
+ # 1669 warnings warnings_default =
+ # ../src/complain.c(318): error #188: enumerated type mixed with another type
+ # 1670 Wconflicts_sr | Wconflicts_rr | Wdeprecated | Wother;
+ # 1671 ^
+ # 1672
+ # 1673../src/complain.c(393): error #188: enumerated type mixed with another type
+ # 1674 warnings w = 1 << wbit;
+ # 1675 ^
+ #
+ # ICC: -wr3179
+ #
+ # char const *usefulness
+ # = rule_useless_in_grammar_p (&rules[r]) ? "useless-in-grammar"
+ # : rule_useless_in_parser_p (&rules[r]) ? "useless-in-parser"
+ # : "useful";
+ #
+ # gives
+ #
+ # error #3179: deprecated conversion of string literal to char* (should be const char*)
+ #
+ # ICC: -wr2259 (that's in C, in spite of what the error messages which seems to be about C++).
+ # error #2259: non-pointer conversion from "int" to "yybool={signed char}" may lose significant bits
+ # yybool yynormal YY_ATTRIBUTE_UNUSED = yystackp->yysplitPoint == YY_NULLPTR;
+ # ^
warn_common='-Wall -Wextra
-Wcast-align -Wchar-subscripts
-fparse-all-comments -Wdocumentation
-Wformat -Wimplicit-fallthrough -Wnull-dereference
-Wno-sign-compare -Wno-tautological-constant-out-of-range-compare
-Wpointer-arith -Wshadow
- -Wwrite-strings'
+ -Wwrite-strings
+ -wr188 -wr2259 -wr3179'
warn_c='-Wbad-function-cast -Wstrict-prototypes'
warn_cxx='-Wextra-semi -Wnoexcept -Wold-style-cast -Wundefined-func-template
-Wweak-vtables'