summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim@lrde.epita.fr>2015-08-11 14:05:29 +0200
committerAkim Demaille <akim@lrde.epita.fr>2015-08-12 13:56:06 +0200
commit3e8d1bd05331163c8047b2ab2a4c9fc38de5f35e (patch)
tree31e1064d8d5969c70819a2c6a98d4236b552963c /configure.ac
parent32ea6125e32103c7f3f78d20723056801c752acc (diff)
downloadbison-3e8d1bd05331163c8047b2ab2a4c9fc38de5f35e.tar.gz
tests: beware that clang warns about "#define private public"
We use this trick to write some test about internal details. But since we use -Werror, clang++ 3.6 dies issueing a warning about it. * configure.ac (warn_tests): Disable this warning.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 35de4cee..5dc274fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,7 +90,12 @@ if test "$enable_gcc_warnings" = yes; then
# -fno-color-diagnostics: Clang's use of colors in the error
# messages is confusing the tests looking at the compiler's output
# (e.g., synclines.at).
- warn_tests='-Wundef -pedantic -Wsign-compare -fno-color-diagnostics'
+ #
+ # -Wno-keyword-macro: We use the "#define private public" dirty
+ # trick in the test suite to check some private implementation
+ # details for lalr1.cc.
+ warn_tests='-Wundef -pedantic -Wsign-compare -fno-color-diagnostics
+ -Wno-keyword-macro'
AC_LANG_PUSH([C])
# Clang supports many of GCC's -W options, but only issues warnings