summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2019-01-14 08:40:06 +0100
committerAkim Demaille <akim.demaille@gmail.com>2019-01-14 19:45:01 +0100
commit3551d51dd9719778444e0606dd339c4b189c5dcb (patch)
treece028bb6b2cc69f2f24a75a42f077765932f9022 /configure.ac
parent38b17c36daa5b21a1a4f92fa42b13844263dec99 (diff)
downloadbison-3551d51dd9719778444e0606dd339c4b189c5dcb.tar.gz
c++: avoid warnings about extraneous semi-colons
Reported by Derek Clegg. http://lists.gnu.org/archive/html/bug-bison/2019-01/msg00005.html * configure.ac (warn_cxx): Add -Wextra-semi. * data/skeletons/c++.m4: Remove extraneous semi-colon.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7fef652d..e60af602 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,7 +98,7 @@ if test "$enable_gcc_warnings" = yes; then
-fparse-all-comments -Wdocumentation
-Wformat -Wnull-dereference -Wpointer-arith -Wshadow -Wwrite-strings'
warn_c='-Wbad-function-cast -Wstrict-prototypes'
- warn_cxx='-Wnoexcept'
+ warn_cxx='-Wextra-semi -Wnoexcept'
# Warnings for the test suite only.
#
# -fno-color-diagnostics: Clang's use of colors in the error