summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2019-11-01 16:13:46 +0100
committerAkim Demaille <akim.demaille@gmail.com>2019-11-02 16:40:50 +0100
commit3398b0fa905b24cc7aa0fa1409f50525d645d485 (patch)
tree7a36fc5bcdcc1a421b40dedd035ad5dc0adcf9dc /configure.ac
parent2bd1d9e20f805a121b71284c58ef2bfc5e5fd61e (diff)
downloadbison-3398b0fa905b24cc7aa0fa1409f50525d645d485.tar.gz
c++: fix old cast warnings
We still have a few old C casts in lalr1.cc, let's get rid of them. Reported by Frank Heckenbach. Actually, let's monitor all our casts using easy to grep macros. Let's use these macros to use the C++ standard casts when we are in C++. * data/skeletons/c.m4 (b4_cast_define): New. * data/skeletons/glr.c, data/skeletons/glr.cc, * data/skeletons/lalr1.cc, data/skeletons/stack.hh, * data/skeletons/yacc.c: Use it and/or its casts. * tests/actions.at, tests/cxx-type.at, * tests/glr-regression.at, tests/headers.at, tests/torture.at, * tests/types.at: Use YY_CAST instead of C casts. * configure.ac (warn_cxx): Add -Wold-style-cast. * doc/bison.texi: Disable it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e5517d24..5a5d8305 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,7 +107,8 @@ if test "$enable_gcc_warnings" = yes; then
-Wpointer-arith -Wshadow
-Wwrite-strings'
warn_c='-Wbad-function-cast -Wstrict-prototypes'
- warn_cxx='-Wextra-semi -Wnoexcept -Wundefined-func-template -Wweak-vtables'
+ warn_cxx='-Wextra-semi -Wnoexcept -Wold-style-cast -Wundefined-func-template
+ -Wweak-vtables'
# Warnings for the test suite only.
#
# -fno-color-diagnostics: Clang's use of colors in the error