summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim@lrde.epita.fr>2013-10-22 17:32:49 +0200
committerAkim Demaille <akim@lrde.epita.fr>2013-10-22 17:34:22 +0200
commit265640d56ed2eece90efd92f21fc9e614e575724 (patch)
tree71055b461e74478b934e73f637ac4f16a643dcab /configure.ac
parentee9cdb85958b4cdcf138029e54c7c0499d34d8b2 (diff)
downloadbison-265640d56ed2eece90efd92f21fc9e614e575724.tar.gz
install: do not install yacc.1 when --disable-yacc
* configure.ac (ENABLE_YACC): New conditional. (YACC_SCRIPT, YACC_LIBRARY): Remove. * lib/local.mk, src/local.mk: Use the former instead of the latter. * doc/local.mk: Use ENABLE_YACC to avoid installing yacc.1.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 1 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 74d8fced..688803af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -161,16 +161,7 @@ AC_ARG_ENABLE([yacc],
[AC_HELP_STRING([--disable-yacc],
[do not build a yacc command or an -ly library])],
, [enable_yacc=yes])
-case $enable_yacc in
-yes)
- YACC_SCRIPT=src/yacc
- YACC_LIBRARY=lib/liby.a;;
-*)
- YACC_SCRIPT=
- YACC_LIBRARY=;;
-esac
-AC_SUBST([YACC_SCRIPT])
-AC_SUBST([YACC_LIBRARY])
+AM_CONDITIONAL([ENABLE_YACC], [test "$enable_yacc" = yes])
# Checks for programs.
AM_MISSING_PROG([DOT], [dot])