summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2020-05-03 16:05:03 +0200
committerAkim Demaille <akim.demaille@gmail.com>2020-05-03 16:38:34 +0200
commit160df220b14e266b580be04a909ba4427d92e65d (patch)
tree48dffd2f66a9a60e920ad29924a5713c671faeeb /configure.ac
parentda5c072a62a44e1d255baf58b088765a4177e727 (diff)
downloadbison-160df220b14e266b580be04a909ba4427d92e65d.tar.gz
bistromathic: beware of portability of readline
Don't try to build bistromathic if we don't have readline. Reported by Bruno Haible. https://lists.gnu.org/r/bug-bison/2020-05/msg00028.html * configure.ac (ENABLE_BISTROMATHIC): New. * examples/c/bistromathic/local.mk: Use it. * examples/c/bistromathic/bistromathic.test: Exit 77 for skip.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c1b0c182..7e673b51 100644
--- a/configure.ac
+++ b/configure.ac
@@ -331,6 +331,13 @@ AC_MSG_RESULT([$suppfile])
# Whether we cannot run the compiled bison.
AM_CONDITIONAL([CROSS_COMPILING], [test "$cross_compiling" = yes])
+# Build bistromathic if we have the lib and both readline/readline.h
+# and readline/history.h.
+AM_CONDITIONAL([ENABLE_BISTROMATHIC],
+[test "$gl_cv_lib_readline" != no &&
+ test "$ac_cv_header_readline_readline_h" = yes &&
+ test "$ac_cv_header_readline_history_h" = yes])
+
AM_MISSING_PROG([AUTOM4TE], [autom4te])
# Needed by tests/atlocal.in.
AC_SUBST([GCC])