summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2019-09-08 18:48:49 +0200
committerAkim Demaille <akim.demaille@gmail.com>2019-09-11 08:27:27 +0200
commit06a273625bdc34275483626e6f653be24d510093 (patch)
treea6a679147406add9440a484e5c1194b8c2f81ac8 /configure.ac
parentf6fd9be688fa792e83e8f22eb339c92b37417aba (diff)
downloadbison-06a273625bdc34275483626e6f653be24d510093.tar.gz
build: fix distcheck
* configure.ac (gl_LIBOBJS): Adjust so that the generated files are indeed the expected ones.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a9dad57c..38d64609 100644
--- a/configure.ac
+++ b/configure.ac
@@ -297,4 +297,15 @@ AC_SUBST([GCC])
AC_CONFIG_FILES([Makefile
po/Makefile.in
doc/yacc.1])
+
+# Fix LIBOBJS to give the Makefile the right file names. Otherwise
+# compilation works, but with unexpected file names, so clean rules don't
+# remove the actual files and distcheck fails.
+AC_CONFIG_COMMANDS_PRE([
+ case $am__api_version in
+ 1.14*|1.15*) gl_LIBOBJS=`echo "$gl_LIBOBJS" | sed -e 's, lib/, lib/lib_libbison_a-,g'`;;
+ *) gl_LIBOBJS=`echo "$gl_LIBOBJS" | sed -e 's, lib/, lib/libbison_a-,g'`;;
+ esac
+])
+
AC_OUTPUT