summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2020-05-11 08:09:10 +0200
committerAkim Demaille <akim.demaille@gmail.com>2020-05-17 08:28:12 +0200
commitff4d67ede8c5bb4a7f0b3840762464bebade095a (patch)
tree8861454e81f35e651124623a748ec0d349fcddfc /Makefile.am
parent465babb635e551620f2f349496912d90c6738600 (diff)
downloadbison-ff4d67ede8c5bb4a7f0b3840762464bebade095a.tar.gz
CI: add GCC 10 and Clang 10
* .travis.yml: Here. * tests/input.at, tests/regression.at: Beware of clang's -Wdocumentation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 677f9b01..58650e09 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -127,3 +127,7 @@ gen-ChangeLog:
--since=$(gen_start_date) > $$cl.tmp && \
mv -f $$cl.tmp $$cl; \
fi
+
+# Useful to debug.
+.c.i:
+ $(CC) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -o $@ -E $<