summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2020-01-25 19:38:39 +0100
committerAkim Demaille <akim.demaille@gmail.com>2020-01-27 06:41:11 +0100
commitf374310119891f9b7860c56e8141bc8913683197 (patch)
tree6cbecd9840ec44b9f9f5ca36669ad51409ce9f3b /Makefile.am
parent7bfff37f01e5e4a625e31ef624b9f120d3d5e199 (diff)
downloadbison-f374310119891f9b7860c56e8141bc8913683197.tar.gz
examples: add a complete example with all the bells and whistles
* examples/c/bistromathic/Makefile, * examples/c/bistromathic/README.md, * examples/c/bistromathic/bistromathic.test, * examples/c/bistromathic/local.mk, * examples/c/bistromathic/parse.y, * examples/c/bistromathic/scan.l: New. * Makefile.am (AM_YFLAGS_WITH_LINES): Add -Wdangling-alias. * examples/test: Make failure errors easier to read.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e357db17..677f9b01 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,7 +42,7 @@ dependencies = $(BISON_IN) $(src_bison_SOURCES) $(dist_skeletons_DATA)
BISON = $(top_builddir)/tests/bison
BISON_IN = $(top_srcdir)/tests/bison.in
YACC = $(BISON) -o y.tab.c
-AM_YFLAGS_WITH_LINES = --defines -Werror -Wall --report=all
+AM_YFLAGS_WITH_LINES = --defines -Werror -Wall,dangling-alias --report=all
AM_YFLAGS = $(AM_YFLAGS_WITH_LINES) --no-lines
# Initialization before completion by local.mk's.