summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <akim@lrde.epita.fr>2013-02-27 15:41:55 +0100
committerAkim Demaille <akim@lrde.epita.fr>2013-03-04 08:25:32 +0100
commitf1526426cddd0aaef7f54c583b5a8651f2dad482 (patch)
tree890f6406e2a128aab46a4e465bac320613b68896 /Makefile.am
parent7601a471f5b0dee063748c5d4383bc03c6313164 (diff)
downloadbison-f1526426cddd0aaef7f54c583b5a8651f2dad482.tar.gz
build: stop using bison -y
* Makefile.am (YACC): Pass -o y.tab.c, so that ylwrap is happy, and yet we don't pass --yacc to bison. (AM_YFLAGS): Disable Yacc warnings.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 34edfc78..7a752d7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,8 +32,8 @@ EXTRA_DIST = .prev-version .version \
## version of Bison nearby...
BISON = $(top_builddir)/tests/bison
BISON_IN = $(top_srcdir)/tests/bison.in
-YACC = $(BISON) -y
-AM_YFLAGS = -d -v --warnings=all,error --report=all
+YACC = $(BISON) -o y.tab.c
+AM_YFLAGS = -d -v -Werror -Wall -Wno-yacc --report=all
# Initialization before completion by local.mk's.
AM_CFLAGS = $(WARN_CFLAGS)