summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <akim@lrde.epita.fr>2012-05-24 13:37:28 +0200
committerAkim Demaille <akim@lrde.epita.fr>2012-05-24 13:54:55 +0200
commitc547693afdacf4b865027d3bb8c53f601eadb5ae (patch)
tree5c50d034654455799c1af2f37bfe931c1118ff34 /Makefile.am
parent775673717fc9b7e5174418f7420ba21040a8e675 (diff)
parent3cd7c0bfce1635ea344947aaf8fda4000b817a80 (diff)
downloadbison-c547693afdacf4b865027d3bb8c53f601eadb5ae.tar.gz
Merge tag 'v2.5.1_rc2'
Bison 2.5.1_rc2. * tag 'v2.5.1_rc2': (34 commits) Bison 2.5.1_rc2. doc: fixes. build: fix ChangeLog generation. c++: compute the header guards. skeletons: remove support for unused directive. lalr1.cc: improve Doxygen documentation. lalr1.cc: extract stack.hh. news: convert to double quotes. space changes. build: do not prototype flex-generated functions. build: fix ChangeLog generation. Bison 2.5.1_rc1. tests: save/restore Autotest special files when checking XML support. tests: AT_SAVE_SPECIAL_FILES / AT_RESTORE_SPECIAL_FILES. tests: honor TESTSUITEFLAGS in all the check targets. build: do not enable c++ warnings on 0 when nullptr is not supported. maint: update gnulib. build: config.in.h. build: move silent rules. glr.c: reduce variable scopes. maint: maintainer-release-check. maint: shush a syntax-check. maint: prefer "commit message" to "log entry". command line: fix minor leaks. maint: we no longer maintain the ChangeLog. maint: fix the generation of the synclines for bison's parser. maint: regen. maint: import the xmemdup0 gnulib module. maint: remove left-over gnulib modules. maint: ignore files imported by autopoint. build: AC_PROG_LEX: use more readable variable names. maint: regen src/parse-gram.[ch] maint: simplify parse-gram.y maint: s/strncpy/memcpy/, when equivalent Conflicts: Makefile.am NEWS data/glr.c data/lalr1.cc data/stack.hh examples/rpcalc/local.mk src/flex-scanner.h src/getargs.c src/output.c src/parse-gram.c src/parse-gram.h src/parse-gram.y tests/Makefile.am tests/bison.in
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index feb55681..5fae4ce5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -88,11 +88,13 @@ update-package-copyright-year:
gen_start_date = 2012-01-16
.PHONY: gen-ChangeLog
gen-ChangeLog:
- $(AM_V_GEN)if test -d .git; then \
- $(top_srcdir)/build-aux/gitlog-to-changelog \
- --no-cluster \
- --amend=$(srcdir)/build-aux/git-log-fix \
- --since=$(gen_start_date) > $(distdir)/cl-t; \
- rm -f $(distdir)/ChangeLog; \
- mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ $(AM_V_GEN)if test -d $(srcdir)/.git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ --strip-tab \
+ --strip-cherry-picked \
+ --no-cluster \
+ --amend=$(srcdir)/build-aux/git-log-fix \
+ --since=$(gen_start_date) > $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
fi