summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2018-10-07 10:11:05 +0200
committerAkim Demaille <akim.demaille@gmail.com>2018-10-07 10:41:40 +0200
commitc164fc0822e8dcbbde156deb9fe3c7ae5f4b5a87 (patch)
treece404a8522501f89a8297adf39b294fc6fddb511 /Makefile.am
parent25347d885c73e34297f4d8d1bfaf3e5627068065 (diff)
downloadbison-c164fc0822e8dcbbde156deb9fe3c7ae5f4b5a87.tar.gz
build: fix distcheck
Now that distcheck no longer fails (see previous commit), let's address the shortcomings. * Makefile.am (CLEANDIRS, clean-local): New. * doc/local.mk, examples/calc++/local.mk, examples/local.mk, * examples/mfcalc/local.mk, examples/rpcalc/local.mk, * src/local.mk (CLEANDIRS): Get rid of Apple's *.dSYM directories. (CLEANFILES): Get rid of *.output files. * examples/variant-11.yy, examples/variant.yy: Don't generate any of the auxiliary files (location.hh and the like).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d03a65b0..ffd06423 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,6 +43,7 @@ AM_CFLAGS = $(WARN_CFLAGS)
# instead of "-Ilib" avoids infinite recursions on #include_next.
AM_CPPFLAGS = -I. -I./lib -I$(top_srcdir) -I$(top_srcdir)/lib
BUILT_SOURCES =
+CLEANDIRS =
CLEANFILES =
DISTCLEANFILES =
EXTRA_DIST += $(dist_TESTS)
@@ -64,6 +65,9 @@ include lib/local.mk
include src/local.mk
include tests/local.mk
+clean-local:
+ rm -rf $(CLEANDIRS)
+
# See comments in build-aux/git-version-gen. However, we make .version depend
# on configure so that .version and VERSION/PACKAGE_VERSION stay in sync in the
# working copy (for example, when you run autoreconf && make). Allowing these