summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoel E. Denny <jdenny@clemson.edu>2009-08-04 18:06:20 -0400
committerJoel E. Denny <jdenny@clemson.edu>2009-08-04 21:32:58 -0400
commitac2def5602c14b52869a761bc0309ab55c1cc869 (patch)
treec25a03747de36b5fee4961247f90559ca970facb /Makefile.am
parentdbbb64f09180b8749e3a91d3559e13b933cd15c8 (diff)
downloadbison-ac2def5602c14b52869a761bc0309ab55c1cc869.tar.gz
maint: automate b4_copyright updates.
* Makefile.am (update-b4-copyright): New target rule. * build-aux/Makefile.am (EXTRA_DIST): Add update-b4-copyright. * build-aux/update-b4-copyright: New. * data/yacc.c: Remove stray characters around b4_copyright invocations. (cherry picked from commit 269e222e24b03ccc4ab7881d960750ddeb131b05) Conflicts: build-aux/local.mk data/yacc.c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index adf71e54..036efac7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,3 +57,10 @@ $(top_srcdir)/.version: configure
echo $(VERSION) > $@-t && mv $@-t $@
dist-hook:
echo $(VERSION) > $(distdir)/.tarball-version
+
+.PHONY: update-b4-copyright
+update-b4-copyright:
+ find data -type f \
+ | grep -v -E '^data/bison.m4$$' \
+ | xargs $(build_aux)/$@
+ @echo 'warning: src/parse-gram.[hc] may need to be regenerated.'