summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoel E. Denny <jdenny@clemson.edu>2010-01-21 12:18:45 -0500
committerJoel E. Denny <jdenny@clemson.edu>2010-01-21 17:00:37 -0500
commit8ebc7dca6335c37a59b4884a34185183d6d1bf91 (patch)
tree24c97395032bd42a1e1a421228cc82e5f30b70b5 /Makefile.am
parentf0a43dd1bb46328c99b43e069df5b52fe84d5da1 (diff)
downloadbison-8ebc7dca6335c37a59b4884a34185183d6d1bf91.tar.gz
maint: automate PACKAGE_COPYRIGHT_YEAR update, and update it.
* HACKING (Release Procedure): Update notes on copyright years. * Makefile.am (update-package-copyright-year): New target rule. * build-aux/update-package-copyright-year: New file. * cfg.mk (update-copyright): Add update-package-copyright-year as a dependency. (cherry picked from commit af8a609a90c48d1a7e6ea9e31dba4fbad6c7fbed)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8a705de6..fcd91a74 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,9 +57,11 @@ $(top_srcdir)/.version: configure
dist-hook:
echo $(VERSION) > $(distdir)/.tarball-version
-.PHONY: update-b4-copyright
+.PHONY: update-b4-copyright update-package-copyright-year
update-b4-copyright:
find data -type f \
| grep -v -E '^data/bison.m4$$' \
| xargs $(build_aux)/$@
@echo 'warning: src/parse-gram.[hc] may need to be regenerated.'
+update-package-copyright-year:
+ $(build_aux)/$@ configure.ac