summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <akim@lrde.epita.fr>2012-07-05 16:09:17 +0200
committerAkim Demaille <akim@lrde.epita.fr>2012-07-05 16:16:10 +0200
commit813f7d34824153ac3259fdd34fce5710d3b7606c (patch)
treebeee6ab213e653d4b28c585b77a0ca6905ea7bd1 /Makefile.am
parent7a9e6d65ea4e91760ad7a44c00ccbe422621b926 (diff)
downloadbison-813f7d34824153ac3259fdd34fce5710d3b7606c.tar.gz
build: fix gen-ChangeLog call.
* Makefile.am: Be sure to catch errors, and fix option name
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index eef413fc..d5d3db28 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,13 +66,14 @@ update-package-copyright-year:
gen_start_date = 2012-01-16
.PHONY: gen-ChangeLog
gen-ChangeLog:
- $(AM_V_GEN)if test -d $(srcdir)/.git; then \
- $(top_srcdir)/build-aux/gitlog-to-changelog \
- --strip-tab \
- --strip-cherry-picked \
- --no-cluster \
- --amend=$(srcdir)/build-aux/git-log-fix \
- --since=$(gen_start_date) > $(distdir)/cl-t; \
- rm -f $(distdir)/ChangeLog; \
- mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ $(AM_V_GEN)if test -d $(srcdir)/.git; then \
+ cl=$(distdir)/ChangeLog && \
+ rm -f $$cl.tmp && \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ --strip-tab \
+ --strip-cherry-pick \
+ --no-cluster \
+ --amend=$(srcdir)/build-aux/git-log-fix \
+ --since=$(gen_start_date) > $$cl.tmp && \
+ mv -f $$cl.tmp $$cl; \
fi