summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <akim@lrde.epita.fr>2012-07-06 10:58:26 +0200
committerAkim Demaille <akim@lrde.epita.fr>2012-07-06 11:00:57 +0200
commit60aa04a236004d3d03f00aeaf07b643a52ef0760 (patch)
tree497f52b8113bbdd4effe5e9343a9b13a96184cca /Makefile.am
parentccdc1577ef7fb32a5e30cb655337e7cd42b98987 (diff)
parenta59a6ddef4a130b16d619e561a5d9886e305ac36 (diff)
downloadbison-60aa04a236004d3d03f00aeaf07b643a52ef0760.tar.gz
Merge remote-tracking branch 'origin/maint'
* origin/maint: maint: update release instructions maint: post-release administrivia version 2.5.90 build: fix gen-ChangeLog call. gnulib: update. tests: fix SKIP_IF for Java. api.prefix: incompatible with %name-prefix. api.prefix: strengthen the tests and fix push-parsers. skeletons: style changes. NEWS: minor changes. api.prefix: improve the documentation for YYDEBUG. gnulib: update. Conflicts: NEWS cfg.mk data/bison.m4 doc/bison.texi m4/.gitignore tests/calc.at tests/headers.at
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 5fae4ce5..ab3460d8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -88,13 +88,14 @@ update-package-copyright-year:
gen_start_date = 2012-01-16
.PHONY: gen-ChangeLog
gen-ChangeLog:
- $(AM_V_GEN)if test -d $(srcdir)/.git; then \
- $(top_srcdir)/build-aux/gitlog-to-changelog \
- --strip-tab \
- --strip-cherry-picked \
- --no-cluster \
- --amend=$(srcdir)/build-aux/git-log-fix \
- --since=$(gen_start_date) > $(distdir)/cl-t; \
- rm -f $(distdir)/ChangeLog; \
- mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ $(AM_V_GEN)if test -d $(srcdir)/.git; then \
+ cl=$(distdir)/ChangeLog && \
+ rm -f $$cl.tmp && \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ --strip-tab \
+ --strip-cherry-pick \
+ --no-cluster \
+ --amend=$(srcdir)/build-aux/git-log-fix \
+ --since=$(gen_start_date) > $$cl.tmp && \
+ mv -f $$cl.tmp $$cl; \
fi