summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2012-01-19 09:07:02 +0100
committerJim Meyering <meyering@redhat.com>2012-01-20 09:33:14 +0100
commit5ef4a3c71cfd6c07e71462944281c284780312c1 (patch)
treebed9257f9c6ae4c87ddd0f56c53545d632425b4e /Makefile.am
parent4aa9d1ff9ca9b838fe02a9bfe5ae4b0f935e5451 (diff)
downloadbison-5ef4a3c71cfd6c07e71462944281c284780312c1.tar.gz
maint: generate ChangeLog from git log
* Makefile.am (gen-ChangeLog): New rule. (dist-hook): Depend on it. (EXTRA_DIST): Distribute the two ChangeLog-* files. * bootstrap.conf (gnulib_modules): Add gitlog-to-changelog. (bootstrap_post_import_hook): Ensure that ChangeLog exists. * build-aux/git-log-fix: New file. * ChangeLog-2012: Renamed ... * ChangeLog: ... from this. * ChangeLog-1998: Renamed ... * OChangeLog: ...from this * .gitignore: Add ChangeLog.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 2a9ad2b1..097a6349 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,8 +27,7 @@ aclocaldir = @aclocaldir@
aclocal_DATA = m4/bison-i18n.m4
EXTRA_DIST = .prev-version .version \
- cfg.mk \
- OChangeLog PACKAGING
+ cfg.mk ChangeLog-1998 ChangeLog-2012 PACKAGING
# Initialization before completion by local.mk's.
AM_CFLAGS = $(WARN_CFLAGS)
@@ -62,7 +61,7 @@ include tests/local.mk
BUILT_SOURCES += $(top_srcdir)/.version
$(top_srcdir)/.version: configure
echo $(VERSION) > $@-t && mv $@-t $@
-dist-hook:
+dist-hook: gen-ChangeLog
echo $(VERSION) > $(distdir)/.tarball-version
.PHONY: update-b4-copyright update-package-copyright-year
@@ -73,3 +72,15 @@ update-b4-copyright:
@echo 'warning: src/parse-gram.[hc] may need to be regenerated.'
update-package-copyright-year:
$(build_aux)/$@ configure.ac
+
+gen_start_date = 2012-01-16
+.PHONY: gen-ChangeLog
+gen-ChangeLog:
+ $(AM_V_GEN)if test -d .git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ --no-cluster \
+ --amend=$(srcdir)/build-aux/git-log-fix \
+ --since=$(gen_start_date) > $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi