summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2018-12-26 08:44:01 +0100
committerAkim Demaille <akim.demaille@gmail.com>2018-12-26 08:44:01 +0100
commit50285ff06695a8c5d977337f0ede3a4d72aa048d (patch)
tree5dcba1abd2717fc486ec42bdaeec14fd9c45d464 /Makefile.am
parentf44fcd30ea61c6d65cf4a0e4f5ab27ea9da97b84 (diff)
downloadbison-50285ff06695a8c5d977337f0ede3a4d72aa048d.tar.gz
examples: fix dependencies
Commit 112ccb5ed73ba5c64b0b5300d8b9b686f02f094c moved the skeletons from dist_pkgdata_DATA to dist_skeletons_DATA, hence broke the dependencies. * Makefile.am (dependencies): New. Use it where appropriate.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6911bc78..4e699383 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,6 +29,13 @@ EXTRA_DIST = .prev-version .version cfg.mk PACKAGING \
dist_doc_DATA = AUTHORS COPYING NEWS README THANKS TODO
+# Let generated files (e.g., from exampkles/) depend on this variable,
+# to make sure they are regenerated when there are changes in Bison.
+#
+# Don't depend on $(BISON) otherwise we would rebuild these files
+# in srcdir, including during distcheck, which is forbidden.
+dependencies = $(BISON_IN) $(dist_skeletons_DATA)
+
## Running the bison from this tarball. To generate our own parser,
## but also to run the tests. Of course, you ought to keep a sane
## version of Bison nearby...