summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2021-01-16 18:05:57 +0100
committerAkim Demaille <akim.demaille@gmail.com>2021-01-16 18:05:57 +0100
commit4f6d1f5fdcd131694c5b2d2f0f8d2e393c735624 (patch)
treefddf1ccfc37f9a847eba4b8b9af8e0a4fdc6b1e0 /Makefile.am
parent4fd2e5c22a59bd330371e8dcb858d26b47598a9d (diff)
downloadbison-4f6d1f5fdcd131694c5b2d2f0f8d2e393c735624.tar.gz
package: codespell
* data/skeletons/glr2.cc, src/parse-gram.y: Fix spelling.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7a930c26..41c885ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -140,9 +140,10 @@ gen-ChangeLog:
$(CC) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -o $@ -E $<
.PHONY: codespell
+CODESPELL = codespell
codespell:
$(AM_V_GEN) cd $(srcdir) \
- && codespell \
+ && $(CODESPELL) \
--regex "[\\w\\-'’\`]+\+*" \
--ignore-words-list "ba,circularly,cloneable,copyable,define'd,dout,froms,iff,ifset,od,ois" \
$$(git ls-files data doc lib src tests)