summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2020-05-23 11:11:45 +0200
committerAkim Demaille <akim.demaille@gmail.com>2020-05-23 11:19:27 +0200
commit3fea8fade8e2fad9e5053ff79af0604c3d119994 (patch)
treed92ee355135e749b5a0f7c61e3692729f3179fee /Makefile.am
parente7aff571223ee73dd0281a94c510f0196817a8fa (diff)
downloadbison-3fea8fade8e2fad9e5053ff79af0604c3d119994.tar.gz
style: spell fixes
* Makefile.am (codespell): New. * doc/bison.texi: Fixes. Use @option for options. * src/lssi.c, src/lssi.h, src/parse-simulation.h, src/state-item.c: Fix spellos.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 58650e09..7db4fe11 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -131,3 +131,11 @@ gen-ChangeLog:
# Useful to debug.
.c.i:
$(CC) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -o $@ -E $<
+
+.PHONY: codespell
+codespell:
+ $(AM_V_GEN) cd $(srcdir) \
+ && codespell \
+ --regex "[\\w\\-'’\`]+\+*" \
+ --ignore-words-list "ba,circularly,cloneable,copyable,define'd,dout,froms,iff,ifset,od,ois" \
+ $$(git ls-files data doc lib src tests)