summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <akim@lrde.epita.fr>2012-05-22 16:47:08 +0200
committerAkim Demaille <akim@lrde.epita.fr>2012-05-23 14:24:30 +0200
commit3f32a0d287afe7ab91603cfc133256deca09f144 (patch)
tree2f0b8c70d43b15fe4970cdc95252f319821a6f0d /Makefile.am
parent22172d473180c53755290f13ebd2d53e12e74fe0 (diff)
downloadbison-3f32a0d287afe7ab91603cfc133256deca09f144.tar.gz
build: fix ChangeLog generation.
* gnulib: Update to get newest gitlog-to-changelog. * bootstrap: Update. * Makefile.am (gen-ChangeLog): Fix for Bison's git log style.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 11 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index eaafcaac..eef413fc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -56,8 +56,8 @@ dist-hook: gen-ChangeLog
.PHONY: update-b4-copyright update-package-copyright-year
update-b4-copyright:
- $(AM_V_GEN)find data -type f \
- | grep -v -E '^data/bison.m4$$' \
+ $(AM_V_GEN) find data -type f \
+ | grep -v -E '^data/bison.m4$$' \
| xargs $(build_aux)/$@
@echo 'warning: src/parse-gram.[hc] may need to be regenerated.'
update-package-copyright-year:
@@ -66,11 +66,13 @@ update-package-copyright-year:
gen_start_date = 2012-01-16
.PHONY: gen-ChangeLog
gen-ChangeLog:
- $(AM_V_GEN)if test -d $(srcdir)/.git; then \
- $(top_srcdir)/build-aux/gitlog-to-changelog \
- --no-cluster \
- --amend=$(srcdir)/build-aux/git-log-fix \
- --since=$(gen_start_date) > $(distdir)/cl-t; \
- rm -f $(distdir)/ChangeLog; \
- mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ $(AM_V_GEN)if test -d $(srcdir)/.git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ --strip-tab \
+ --strip-cherry-picked \
+ --no-cluster \
+ --amend=$(srcdir)/build-aux/git-log-fix \
+ --since=$(gen_start_date) > $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
fi