summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2020-11-14 16:58:31 +0100
committerAkim Demaille <akim.demaille@gmail.com>2020-11-20 06:28:42 +0100
commit336089123f10579fef4bbf1f2f8d3423e752bf3a (patch)
tree5c584d1b394526296ea12e6267e23badc2869ff4 /Makefile.am
parent593724366f714e6c0316c51716cc507309ea9030 (diff)
downloadbison-336089123f10579fef4bbf1f2f8d3423e752bf3a.tar.gz
gnulib: update
* Makefile.am (gitsort): New. Use it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7db4fe11..e0aa88af 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -76,6 +76,12 @@ include tests/local.mk
clean-local:
rm -rf $(CLEANDIRS)
+.PHONY: gitsort
+gitsort:
+ cd $(srcdir) && for i in $$(git ls-files '*.gitignore'); do \
+ LC_ALL=C sort $$i -o $$i; \
+ done
+
# See comments in build-aux/git-version-gen. However, we make .version depend
# on configure so that .version and VERSION/PACKAGE_VERSION stay in sync in the
# working copy (for example, when you run autoreconf && make). Allowing these