summaryrefslogtreecommitdiff
path: root/libctf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libctf/Makefile.am')
-rw-r--r--libctf/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/libctf/Makefile.am b/libctf/Makefile.am
index 3d757e44381..3e51b7b30d0 100644
--- a/libctf/Makefile.am
+++ b/libctf/Makefile.am
@@ -19,11 +19,12 @@
ACLOCAL_AMFLAGS = -I .. -I ../config -I ../bfd
-AUTOMAKE_OPTIONS = dejagnu foreign no-texinfo.tex
+AUTOMAKE_OPTIONS = dejagnu foreign info-in-builddir no-texinfo.tex
-if BUILD_INFO
-SUBDIRS = doc
-endif
+# Variables that we might accumulate conditionally or in subdirs.
+info_TEXINFOS =
+DISTCLEANFILES =
+MAINTAINERCLEANFILES =
# This is where we get zlib from. zlibdir is -L../zlib and zlibinc is
# -I../zlib, unless we were configured with --with-system-zlib, in which
@@ -110,5 +111,9 @@ CONFIG_STATUS_DEPENDENCIES = $(BFDDIR)/development.sh
EXTRA_DEJAGNU_SITE_CONFIG = development.exp
-DISTCLEANFILES = site.exp development.exp
+DISTCLEANFILES += site.exp development.exp
+endif
+
+if BUILD_INFO
+include doc/local.mk
endif