summaryrefslogtreecommitdiff
path: root/ld/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ld/Makefile.am')
-rw-r--r--ld/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/ld/Makefile.am b/ld/Makefile.am
index 0e9bed88f65..0e025867f5f 100644
--- a/ld/Makefile.am
+++ b/ld/Makefile.am
@@ -493,7 +493,8 @@ GENERATED_HFILES = ldgram.h ldemul-list.h deffilep.h
# Require an early dependency on the generated headers, as the dependency
# tracking will not cause them to be built beforehand.
-BUILT_SOURCES = $(GENERATED_HFILES)
+BUILT_SOURCES = $(GENERATED_HFILES) @MAINT@ $(GENERATED_CFILES) \
+ $(ALL_EMULATION_SOURCES) $(ALL_64_EMULATION_SOURCES)
OFILES = ldgram.@OBJEXT@ ldlex-wrapper.@OBJEXT@ lexsup.@OBJEXT@ ldlang.@OBJEXT@ \
mri.@OBJEXT@ ldctor.@OBJEXT@ ldmain.@OBJEXT@ plugin.@OBJEXT@ \
@@ -548,7 +549,7 @@ po/SRC-POTFILES.in: @MAINT@ Makefile
for f in $(SRC_POTFILES); do echo $$f; done | LC_ALL=C sort > $@-tmp \
&& mv $@-tmp $(srcdir)/po/SRC-POTFILES.in
-po/BLD-POTFILES.in: @MAINT@ Makefile $(BLD_POTFILES)
+po/BLD-POTFILES.in: @MAINT@ Makefile
for f in $(BLD_POTFILES); do echo $$f; done | LC_ALL=C sort > $@-tmp \
&& mv $@-tmp $(srcdir)/po/BLD-POTFILES.in