summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index 25fae6b998b..44e858e2667 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -566,8 +566,10 @@ else
AC_LIBOBJ(mremap)
fi
-# Link in zlib if we can. This allows us to write compressed sections.
+# Link in zlib/zstd if we can. This allows us to write compressed sections.
AM_ZLIB
+AC_ZSTD
+AM_CONDITIONAL(HAVE_ZSTD, test "$pkg_cv_ZSTD_LIBS" != "")
AC_ARG_ENABLE([threads],
[[ --enable-threads[=ARG] multi-threaded linking [ARG={auto,yes,no}]]],