summaryrefslogtreecommitdiff
path: root/gdb/testsuite/gdb.asm/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'gdb/testsuite/gdb.asm/configure.in')
-rw-r--r--gdb/testsuite/gdb.asm/configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/gdb/testsuite/gdb.asm/configure.in b/gdb/testsuite/gdb.asm/configure.in
new file mode 100644
index 00000000000..8ff68efbdc5
--- /dev/null
+++ b/gdb/testsuite/gdb.asm/configure.in
@@ -0,0 +1,22 @@
+dnl Process this file file with autoconf to produce a configure script.
+dnl This file is a shell script fragment that supplies the information
+dnl necessary to tailor a template configure script into the configure
+dnl script appropriate for this directory. For more information, check
+dnl any existing configure script.
+
+AC_PREREQ(2.5)
+AC_INIT(asm-source.exp)
+
+CC=${CC-cc}
+AC_SUBST(CC)
+AC_CONFIG_AUX_DIR(`cd $srcdir;pwd`/../../..)
+AC_CANONICAL_SYSTEM
+
+dnl In default case we need to link with some file so use common.inc.
+archinc=common.inc
+case ${target} in
+d10v-*-*) archinc=d10v.inc ;;
+esac
+AC_LINK_FILES($archinc,arch.inc)
+
+AC_OUTPUT(Makefile)