summaryrefslogtreecommitdiff
path: root/gdb/rdi-share/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'gdb/rdi-share/configure.in')
-rw-r--r--gdb/rdi-share/configure.in36
1 files changed, 36 insertions, 0 deletions
diff --git a/gdb/rdi-share/configure.in b/gdb/rdi-share/configure.in
new file mode 100644
index 00000000000..bbda5ccbad0
--- /dev/null
+++ b/gdb/rdi-share/configure.in
@@ -0,0 +1,36 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_PREREQ(2.12.1)
+AC_INIT(adp.h)
+
+AM_INIT_AUTOMAKE(rdi-share, 1.0)
+
+PACKAGE=rdi-share
+VERSION=1.0
+
+dnl Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+AC_PROG_RANLIB
+
+dnl Checks for libraries.
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS(fcntl.h sys/ioctl.h sys/time.h unistd.h sys/filio.h)
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_SIZE_T
+AC_HEADER_TIME
+
+dnl Checks for library functions.
+AC_PROG_GCC_TRADITIONAL
+AC_TYPE_SIGNAL
+AC_FUNC_VPRINTF
+AC_CHECK_FUNCS(gettimeofday select socket strtod strtoul memcpy memmove)
+
+AM_MAINTAINER_MODE
+AM_EXEEXT
+
+AC_OUTPUT(Makefile)