summaryrefslogtreecommitdiff
path: root/etc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'etc/configure.in')
-rw-r--r--etc/configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/etc/configure.in b/etc/configure.in
index 7285d372e74..6b94aac00c7 100644
--- a/etc/configure.in
+++ b/etc/configure.in
@@ -4,6 +4,21 @@ AC_INIT(Makefile.in)
AC_PROG_INSTALL
+# Command-line options.
+# Very limited version of AC_MAINTAINER_MODE.
+AC_ARG_ENABLE([maintainer-mode],
+ [AC_HELP_STRING([--enable-maintainer-mode],
+ [enable make rules and dependencies not useful (and
+ sometimes confusing) to the casual installer])],
+ [case ${enable_maintainer_mode} in
+ yes) MAINT='' ;;
+ no) MAINT='#' ;;
+ *) AC_MSG_ERROR([--enable-maintainer-mode must be yes or no]) ;;
+ esac
+ maintainer_mode=${enableval}],
+ [MAINT='#'])
+AC_SUBST([MAINT])dnl
+
AC_SUBST(datarootdir)
AC_SUBST(docdir)
AC_SUBST(htmldir)