summaryrefslogtreecommitdiff
path: root/sim/ppc/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-06-18 10:45:03 -0400
committerMike Frysinger <vapier@gentoo.org>2021-06-19 16:01:37 -0400
commitd3562f83a7b8a1ae6e333cd5561419d3da18fcb4 (patch)
tree86840ff577904573aa4699c2d2cd7dcb76a8d9a1 /sim/ppc/configure.ac
parentc30420d82a0b743285cf8333f90ca85274632714 (diff)
downloadbinutils-gdb-d3562f83a7b8a1ae6e333cd5561419d3da18fcb4.tar.gz
sim: unify toolchain probing logic
Move these options up to the common dir so we only test & export them once across all ports.
Diffstat (limited to 'sim/ppc/configure.ac')
-rw-r--r--sim/ppc/configure.ac25
1 files changed, 7 insertions, 18 deletions
diff --git a/sim/ppc/configure.ac b/sim/ppc/configure.ac
index 605bdf9f2fb..8efee504207 100644
--- a/sim/ppc/configure.ac
+++ b/sim/ppc/configure.ac
@@ -5,14 +5,6 @@ AC_CONFIG_MACRO_DIRS([../.. ../../config])
AC_PROG_INSTALL
AC_PROG_CC
-# Put a plausible default for CC_FOR_BUILD in Makefile.
-if test "x$cross_compiling" = "xno"; then
- CC_FOR_BUILD='$(CC)'
-else
- CC_FOR_BUILD=gcc
-fi
-CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
-
dnl We don't use gettext, but bfd does. So we do the appropriate checks
dnl to see if there are intl libraries we should link against.
ALL_LINGUAS=
@@ -503,9 +495,6 @@ if test x"$silent" != x"yes" && test x"$sim_xor_endian" != x""; then
fi],[sim_xor_endian=""])dnl
-AC_CANONICAL_SYSTEM
-AC_ARG_PROGRAM
-
case ${host} in
*mingw32*)
AC_DEFINE(USE_WIN32API, 1,
@@ -679,7 +668,13 @@ else
*) realsrcdir=../${srcdir};;
esac
saved_CFLAGS="${CFLAGS}"
- CC="${CC_FOR_BUILD}" CFLAGS="${CFLAGS_FOR_BUILD}" \
+ # Put a plausible default for CC_FOR_BUILD in Makefile.
+ if test "x$cross_compiling" = "xno"; then
+ CC_FOR_BUILD='$(CC)'
+ else
+ CC_FOR_BUILD=gcc
+ fi
+ CC="${CC_FOR_BUILD}" CFLAGS="${CFLAGS_FOR_BUILD-${CFLAGS}}" \
LDFLAGS="${LDFLAGS_FOR_BUILD}" \
${realsrcdir}/configure \
--enable-languages=${enable_languages-all} \
@@ -690,12 +685,6 @@ else
rm -rf $tempdir
fi
-AC_SUBST(CC_FOR_BUILD)
-AC_SUBST(CFLAGS_FOR_BUILD)
-AC_SUBST(CFLAGS)
-AR=${AR-ar}
-AC_SUBST(AR)
-AC_PROG_RANLIB
AC_SUBST(sim_warnings)
AC_SUBST(sim_line_nr)
AC_SUBST(sim_config)