summaryrefslogtreecommitdiff
path: root/opcodes/Makefile.am
diff options
context:
space:
mode:
authorJan Beulich <jbeulich@suse.com>2022-12-12 08:47:26 +0100
committerJan Beulich <jbeulich@suse.com>2022-12-12 08:47:26 +0100
commitbc30b54aef599ec9429044525b2d67f08e0d49a8 (patch)
treedaa2eb266429ea4a81f151a39a75bd9289073128 /opcodes/Makefile.am
parent99f0fb12d544c9489804714f89e7738e60d2ea5d (diff)
downloadbinutils-gdb-bc30b54aef599ec9429044525b2d67f08e0d49a8.tar.gz
x86: remove i386-opc.c
Remove the now empty i386-opc.c. To compensate, tie table generation in opcodes/ to the building of i386-dis.o, despite the file not really depending on the generated data.
Diffstat (limited to 'opcodes/Makefile.am')
-rw-r--r--opcodes/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/opcodes/Makefile.am b/opcodes/Makefile.am
index cb6ff0ebc5e..f657ee88e1c 100644
--- a/opcodes/Makefile.am
+++ b/opcodes/Makefile.am
@@ -160,7 +160,6 @@ TARGET32_LIBOPCODES_CFILES = \
h8300-dis.c \
hppa-dis.c \
i386-dis.c \
- i386-opc.c \
ip2k-asm.c \
ip2k-desc.c \
ip2k-dis.c \
@@ -560,10 +559,9 @@ $(srcdir)/i386%tbl.h $(srcdir)/i386%init.h: @MAINT@ i386-gen$(EXEEXT_FOR_BUILD)
< $(srcdir)/i386-opc.tbl \
| ./i386-gen$(EXEEXT_FOR_BUILD) --srcdir $(srcdir)
-i386-opc.lo: $(srcdir)/i386-tbl.h
-# While not really a dependency, specify i386-init.h here as well to make sure
-# it is generated even if i386-tbl.h is present and up-to-date.
-i386-opc.lo: $(srcdir)/i386-init.h
+# While not really dependencies, specify i386-{init,tbl}.h here as well to
+# make sure they are re-generated as necessary.
+i386-dis.lo: $(srcdir)/i386-tbl.h $(srcdir)/i386-init.h
ia64-gen$(EXEEXT_FOR_BUILD): ia64-gen.o $(BUILD_LIB_DEPS)
$(AM_V_CCLD)$(LINK_FOR_BUILD) ia64-gen.o $(BUILD_LIBS)