summaryrefslogtreecommitdiff
path: root/opcodes/Makefile.am
diff options
context:
space:
mode:
authorJan Beulich <jbeulich@suse.com>2023-01-27 09:20:58 +0100
committerJan Beulich <jbeulich@suse.com>2023-01-27 09:20:58 +0100
commit800c5dd7b39a305af2878dc66e69945ea1aedcc6 (patch)
treef9a75ba6684cc5c3709080fc10d9432047c3f8d8 /opcodes/Makefile.am
parent06ceca3a90174f65e19116c5605750cd4dcaeb6a (diff)
downloadbinutils-gdb-800c5dd7b39a305af2878dc66e69945ea1aedcc6.tar.gz
opcodes: suppress internationalization on build helper tools
While one of the two actually having been instrumented (i386-gen.c) now has that instrumentation dropped, there's still no point in honoring such instrumentation in general (i.e. now for ia64-gen.c only), as that only leads to a waste of resources. With CFILES then being merely an alias of LIBOPCODES_CFILES, drop the former variable altogether.
Diffstat (limited to 'opcodes/Makefile.am')
-rw-r--r--opcodes/Makefile.am18
1 files changed, 1 insertions, 17 deletions
diff --git a/opcodes/Makefile.am b/opcodes/Makefile.am
index acb39c43fd1..578fdc056c5 100644
--- a/opcodes/Makefile.am
+++ b/opcodes/Makefile.am
@@ -277,22 +277,6 @@ LIBOPCODES_CFILES = \
dis-init.c \
disassemble.c
-# C source files that correspond to .o's.
-CFILES = \
- $(LIBOPCODES_CFILES) \
- aarch64-gen.c \
- i386-gen.c \
- ia64-asmtab.c \
- ia64-gen.c \
- ia64-opc-a.c \
- ia64-opc-b.c \
- ia64-opc-f.c \
- ia64-opc-i.c \
- ia64-opc-m.c \
- ia64-opc-d.c \
- s390-mkopc.c \
- z8kgen.c
-
ALL32_MACHINES = $(TARGET32_LIBOPCODES_CFILES:.c=.lo)
ALL64_MACHINES = $(TARGET64_LIBOPCODES_CFILES:.c=.lo)
@@ -341,7 +325,7 @@ stamp-lib: libopcodes.la
libopcodes.a: stamp-lib ; @true
-POTFILES = $(HFILES) $(CFILES)
+POTFILES = $(HFILES) $(LIBOPCODES_CFILES)
po/POTFILES.in: @MAINT@ Makefile
for f in $(POTFILES); do echo $$f; done | LC_ALL=C sort > tmp \
&& mv tmp $(srcdir)/po/POTFILES.in