summaryrefslogtreecommitdiff
path: root/opcodes/Makefile.am
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2020-03-09 08:23:46 -0700
committerH.J. Lu <hjl.tools@gmail.com>2020-03-09 08:23:46 -0700
commit384f368958f2a5bb083660e58e5f8a010e6ad429 (patch)
tree4d4bedb95a27d69fd9dcd2f5c40210d6eaec92a9 /opcodes/Makefile.am
parent0ba678c9ae62c20bb7f2370f51a4e9f1c8f2f409 (diff)
downloadbinutils-gdb-384f368958f2a5bb083660e58e5f8a010e6ad429.tar.gz
x86: Also pass -P to $(CPP) when processing i386-opc.tbl
Since i386-opc.tbl contains '\' to avoid very long lines and i386-gen requires that each instruction must be in one line, also pass -P to $(CPP) to inhibit generation of linemarkers in the output from the preprocessor to support i386-gen. * Makefile.am ($(srcdir)/i386-init.h): Also pass -P to $(CPP). * Makefile.in: Regenerated.
Diffstat (limited to 'opcodes/Makefile.am')
-rw-r--r--opcodes/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/opcodes/Makefile.am b/opcodes/Makefile.am
index 4f06074a85f..7318bf04a8b 100644
--- a/opcodes/Makefile.am
+++ b/opcodes/Makefile.am
@@ -561,7 +561,7 @@ $(srcdir)/i386-tbl.h: $(srcdir)/i386-init.h
@echo $@
$(srcdir)/i386-init.h: @MAINT@ i386-gen$(EXEEXT_FOR_BUILD) i386-opc.tbl i386-reg.tbl i386-opc.h
- $(CPP) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) - \
+ $(CPP) -P $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) - \
< $(srcdir)/i386-opc.tbl \
| ./i386-gen$(EXEEXT_FOR_BUILD) --srcdir $(srcdir)