summaryrefslogtreecommitdiff
path: root/opcodes/Makefile.am
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-06-28 21:26:48 -0400
committerMike Frysinger <vapier@gentoo.org>2021-07-01 18:05:40 -0400
commit2fe36d31f96519ea5ef988d85df1310bc177b5fa (patch)
treed75694894bf0749d04acee940a8168cc7b85884d /opcodes/Makefile.am
parentf375d32b35cef9813410107430963d51600d6896 (diff)
downloadbinutils-gdb-2fe36d31f96519ea5ef988d85df1310bc177b5fa.tar.gz
cgen: split GUILE setting out
This makes it easier to override to point to an older version of guile. The current cgen code doesn't work with guile-2, so need to point to an older guile-1.8.
Diffstat (limited to 'opcodes/Makefile.am')
-rw-r--r--opcodes/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/opcodes/Makefile.am b/opcodes/Makefile.am
index ddae8bd9052..0e04b4c05c4 100644
--- a/opcodes/Makefile.am
+++ b/opcodes/Makefile.am
@@ -363,7 +363,8 @@ CLEANFILES = \
CGENDIR = @cgendir@
CPUDIR = $(srcdir)/../cpu
-CGEN = "`if test -f ../guile/libguile/guile ; then echo ../guile/libguile/guile; else echo guile ; fi` -l ${cgendir}/guile.scm -s"
+GUILE = `if test -f ../guile/libguile/guile ; then echo ../guile/libguile/guile; else echo guile ; fi`
+CGEN = "$(GUILE) -l ${cgendir}/guile.scm -s"
CGENFLAGS = -v
CGENDEPS = \