summaryrefslogtreecommitdiff
path: root/opcodes/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2016-12-28 21:59:34 +1030
committerAlan Modra <amodra@gmail.com>2016-12-28 22:12:11 +1030
commit0fa6f7cee7dedb600799234b1e2d52c5b0da8f96 (patch)
tree3240aac540f1492e5b36d2bb61fd9fa28c109972 /opcodes/Makefile.am
parent9acc85a62eb76c270724bba15c889d2d05567b6a (diff)
downloadbinutils-gdb-0fa6f7cee7dedb600799234b1e2d52c5b0da8f96.tar.gz
Check bfd support for bfd_mips_elf_get_abiflags in mips make rule
The previous scheme with a dependency in opcodes on libbfd.la broke "make distclean". * configure.ac: Revert 2016-12-23. * Makefile.am: Likewise. (MIPS_DEFS): Define. (mips-dis.lo): Add rule. * Makefile.in: Regenerate. * aclocal.m4: Regenerate. * config.in: Regenerate. * configure: Regenerate.
Diffstat (limited to 'opcodes/Makefile.am')
-rw-r--r--opcodes/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/opcodes/Makefile.am b/opcodes/Makefile.am
index 3e9dc54a172..a441febae8a 100644
--- a/opcodes/Makefile.am
+++ b/opcodes/Makefile.am
@@ -300,9 +300,8 @@ ALL_MACHINES = $(TARGET_LIBOPCODES_CFILES:.c=.lo)
OFILES = @BFD_MACHINES@
-# development.sh is used to determine -Werror default, libbfd.la is needed
-# for function availability checks.
-CONFIG_STATUS_DEPENDENCIES = $(BFDDIR)/development.sh ../bfd/libbfd.la
+# development.sh is used to determine -Werror default.
+CONFIG_STATUS_DEPENDENCIES = $(BFDDIR)/development.sh
AM_CPPFLAGS = -I. -I$(srcdir) -I../bfd -I$(INCDIR) -I$(BFDDIR) @HDEFINES@ @INCINTL@
@@ -610,6 +609,19 @@ $(srcdir)/z8k-opc.h: @MAINT@ z8kgen$(EXEEXT_FOR_BUILD)
z8k-dis.lo: $(srcdir)/z8k-opc.h
+MIPS_DEFS=`case \`cat ../bfd/ofiles\` in *elfxx-mips*) echo "-DHAVE_BFD_MIPS_ELF_GET_ABIFLAGS=1";; esac`
+mips-dis.lo: mips-dis.c
+if am__fastdepCC
+ $(LTCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $(MIPS_DEFS) $<
+ $(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Plo
+else
+if AMDEP
+ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
+ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+endif
+ $(LTCOMPILE) -c -o $@ $(MIPS_DEFS) $<
+endif
+
sh-dis.lo: sh-dis.c
if am__fastdepCC
$(LTCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ @archdefs@ $(srcdir)/sh-dis.c