summaryrefslogtreecommitdiff
path: root/opcodes/Makefile.am
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2007-03-15 14:31:24 +0000
committerH.J. Lu <hjl.tools@gmail.com>2007-03-15 14:31:24 +0000
commit0b1cf022c8646c5065eed31d3b2889d7a679f88c (patch)
tree783e3cc3c36fc3abd845672cce7d52d1367a2a3d /opcodes/Makefile.am
parent187b3d5d7fbc4785ff07c9d35e5b3b534818102d (diff)
downloadbinutils-gdb-0b1cf022c8646c5065eed31d3b2889d7a679f88c.tar.gz
gas/
2007-03-15 H.J. Lu <hongjiu.lu@intel.com> * Makefile.am: Run "make dep-am". * Makefile.in: Regenerated. * config/tc-i386.c: Include "opcodes/i386-opc.h" instead of "opcode/i386.h". (md_begin): Check reg_name != NULL for the last entry in i386_regtab. * config/tc-i386.h: Move many entries to opcode/i386.h and opcodes/i386-opc.h. * configure.in (need_opcodes): Set true for i386. * configure: Regenerated. include/opcode/ 2007-03-15 H.J. Lu <hongjiu.lu@intel.com> * i386.h: Add entries from config/tc-i386.h and move tables to opcodes/i386-opc.h. opcodes/ 2007-03-15 H.J. Lu <hongjiu.lu@intel.com> * Makefile.am (CFILES): Add i386-opc.c. (ALL_MACHINES): Add i386-opc.lo. Run "make dep-am". * Makefile.in: Regenerated. * configure.in: Add i386-opc.lo for bfd_i386_arch. * configure: Regenerated. * i386-dis.c: Include "opcode/i386.h". (MAXLEN): Renamed to MAX_MNEM_SIZE. Remove definition. (FWAIT_OPCODE): Remove definition. (UNIXWARE_COMPAT): Renamed to SYSV386_COMPAT. Remove definition. (MAX_OPERANDS): Remove definition. * i386-opc.c: New file. * i386-opc.h: Likewise.
Diffstat (limited to 'opcodes/Makefile.am')
-rw-r--r--opcodes/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/opcodes/Makefile.am b/opcodes/Makefile.am
index 629ca15940e..b929ab4092a 100644
--- a/opcodes/Makefile.am
+++ b/opcodes/Makefile.am
@@ -93,6 +93,7 @@ CFILES = \
i370-dis.c \
i370-opc.c \
i386-dis.c \
+ i386-opc.c \
i860-dis.c \
i960-dis.c \
ia64-dis.c \
@@ -238,6 +239,7 @@ ALL_MACHINES = \
h8500-dis.lo \
hppa-dis.lo \
i386-dis.lo \
+ i386-opc.lo \
i370-dis.lo \
i370-opc.lo \
i860-dis.lo \
@@ -777,7 +779,9 @@ i370-opc.lo: i370-opc.c sysdep.h config.h $(INCDIR)/ansidecl.h \
$(INCDIR)/opcode/i370.h
i386-dis.lo: i386-dis.c $(INCDIR)/dis-asm.h $(BFD_H) \
$(INCDIR)/ansidecl.h $(INCDIR)/symcat.h sysdep.h config.h \
- $(INCDIR)/ansidecl.h opintl.h
+ $(INCDIR)/ansidecl.h opintl.h $(INCDIR)/opcode/i386.h
+i386-opc.lo: i386-opc.c sysdep.h config.h $(INCDIR)/ansidecl.h \
+ i386-opc.h $(INCDIR)/opcode/i386.h
i860-dis.lo: i860-dis.c $(INCDIR)/dis-asm.h $(BFD_H) \
$(INCDIR)/ansidecl.h $(INCDIR)/symcat.h $(INCDIR)/opcode/i860.h
i960-dis.lo: i960-dis.c sysdep.h config.h $(INCDIR)/ansidecl.h \