summaryrefslogtreecommitdiff
path: root/libiberty/configure.ac
diff options
context:
space:
mode:
authorDJ Delorie <dj@redhat.com>2013-06-01 01:01:44 +0000
committerDJ Delorie <dj@redhat.com>2013-06-01 01:01:44 +0000
commita4818a052efb4cea976a03a2f7cb0b38b23d12d0 (patch)
tree0f665116d269a9f721221ebba5962264e55c7668 /libiberty/configure.ac
parentc5c412da3cd0e5af50884606dde3ea6d7dbd0c89 (diff)
downloadbinutils-gdb-a4818a052efb4cea976a03a2f7cb0b38b23d12d0.tar.gz
merge from gcc
Diffstat (limited to 'libiberty/configure.ac')
-rw-r--r--libiberty/configure.ac46
1 files changed, 25 insertions, 21 deletions
diff --git a/libiberty/configure.ac b/libiberty/configure.ac
index c7638942644..fcea46f6c7b 100644
--- a/libiberty/configure.ac
+++ b/libiberty/configure.ac
@@ -128,6 +128,31 @@ if test $cross_compiling = no && test $multilib = yes \
cross_compiling=maybe
fi
+# We may wish to install the target headers somewhere.
+AC_MSG_CHECKING([whether to install libiberty headers and static library])
+dnl install-libiberty is disabled by default
+
+AC_ARG_ENABLE(install-libiberty,
+[ --enable-install-libiberty Install headers and library for end users],
+enable_install_libiberty=$enableval,
+enable_install_libiberty=no)dnl
+
+# Option parsed, now set things appropriately.
+case x"$enable_install_libiberty" in
+ xyes|x)
+ target_header_dir=libiberty
+ ;;
+ xno)
+ target_header_dir=
+ ;;
+ *)
+ # This could be sanity-checked in various ways...
+ target_header_dir="${enable_install_libiberty}"
+ ;;
+esac
+AC_MSG_RESULT($enable_install_libiberty)
+AC_MSG_NOTICE([target_header_dir = $target_header_dir])
+
GCC_NO_EXECUTABLES
AC_PROG_CC
AC_SYS_LARGEFILE
@@ -492,27 +517,6 @@ if test -n "${with_target_subdir}"; then
esac
- # We may wish to install the target headers somewhere.
- AC_ARG_ENABLE(install-libiberty,
- [ --enable-install-libiberty Install headers for end users],
- enable_install_libiberty=$enableval,
- enable_install_libiberty=no)dnl
-
- # Option parsed, now set things appropriately.
- case x"$enable_install_libiberty" in
- xyes|x)
- target_header_dir=libiberty
- ;;
- xno)
- target_header_dir=
- ;;
- *)
- # This could be sanity-checked in various ways...
- target_header_dir="${enable_install_libiberty}"
- ;;
- esac
-
-
else
# Not a target library, so we set things up to run the test suite.