summaryrefslogtreecommitdiff
path: root/libiberty/configure.ac
diff options
context:
space:
mode:
authorDJ Delorie <dj@redhat.com>2010-10-06 23:01:30 +0000
committerDJ Delorie <dj@redhat.com>2010-10-06 23:01:30 +0000
commit9711ae4d9fb353051cbce8d4f72ce25bdf988f74 (patch)
tree84dde83f5042262f2c4471750a0142eb633e9d0f /libiberty/configure.ac
parentb98aa77cb421596fe1a8cc61737bffd021f282ea (diff)
downloadbinutils-gdb-9711ae4d9fb353051cbce8d4f72ce25bdf988f74.tar.gz
merge from gcc
Diffstat (limited to 'libiberty/configure.ac')
-rw-r--r--libiberty/configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/libiberty/configure.ac b/libiberty/configure.ac
index 4de83f95ada..8b7be1835f4 100644
--- a/libiberty/configure.ac
+++ b/libiberty/configure.ac
@@ -351,6 +351,7 @@ funcs="$funcs vprintf"
funcs="$funcs vsnprintf"
funcs="$funcs vsprintf"
funcs="$funcs waitpid"
+funcs="$funcs setproctitle"
# Also in the old function.def file: alloca, vfork, getopt.
@@ -373,7 +374,8 @@ if test "x" = "y"; then
on_exit \
psignal pstat_getdynamic pstat_getstatic putenv \
random realpath rename rindex \
- sbrk setenv sigsetmask snprintf stpcpy stpncpy strcasecmp strchr strdup \
+ sbrk setenv setproctitle sigsetmask snprintf stpcpy stpncpy strcasecmp strchr \
+ strdup \
strerror strncasecmp strndup strrchr strsignal strstr strtod strtol \
strtoul strverscmp sysconf sysctl sysmp \
table times tmpnam \
@@ -533,6 +535,16 @@ fi
AC_SUBST(CHECK)
AC_SUBST(target_header_dir)
+# check for prctl PR_SET_NAME
+AC_RUN_IFELSE([AC_LANG_SOURCE([[
+#include <sys/prctl.h>
+int main()
+{
+ return (prctl(PR_SET_NAME, "foo") == 0) ? 0 : 1;
+}
+]])], AC_DEFINE(HAVE_PRCTL_SET_NAME, 1,
+ [Define if you have prctl PR_SET_NAME]))
+
case "${host}" in
*-*-cygwin* | *-*-mingw*)
AC_DEFINE(HAVE_SYS_ERRLIST)