summaryrefslogtreecommitdiff
path: root/libiberty/configure.ac
diff options
context:
space:
mode:
authorJoel Brobecker <brobecker@adacore.com>2015-11-06 13:39:19 -0800
committerJoel Brobecker <brobecker@adacore.com>2015-11-06 13:39:58 -0800
commit82ef0f70744ca47057b9e95cd926dbcb25ebb0c8 (patch)
treefd8a8c523c3231d0ca55cb306e322e1680c36a00 /libiberty/configure.ac
parented60fec722981ecfbd9d1c46b4a2294b228711e9 (diff)
downloadbinutils-gdb-82ef0f70744ca47057b9e95cd926dbcb25ebb0c8.tar.gz
Do not use libiberty's getpagesize on Android
Building libiberty on Android currently fails with the error message shown below. This was discovered by trying to build GDBserver for Android, which stopped building after libiberty became a GDBserver dependency. Here is the error message: [...]/getpagesize.c:64:1: error: redefinition of 'getpagesize' In file included from /[...]/getpagesize.c:34:0: /[...]/usr/include/unistd.h:171:23: note: previous definition of 'getpagesize' was here And looking at the definition, one can see that it defined as a static inline function... static __inline__ int getpagesize(void) { extern unsigned int __page_size; return __page_size; } ... which explains why the AC_CHECK_FUNCS test failed to detect the function, since there is no associated symbol to be linked in. This patch prevents getpagesize.c to be compiled in by hard-coding the fact that getpagesize is available on android hosts. libiberty/ChangeLog: * configure.ac: Set AC_CV_FUNC_GETPAGESIZE to "yes" on Android hosts. * configure: Regenerate.
Diffstat (limited to 'libiberty/configure.ac')
-rw-r--r--libiberty/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/libiberty/configure.ac b/libiberty/configure.ac
index 868be8e72d1..e21e3aa5809 100644
--- a/libiberty/configure.ac
+++ b/libiberty/configure.ac
@@ -600,6 +600,12 @@ if test -z "${setobjs}"; then
case "${host}" in
+ *-*-android*)
+ # On android, getpagesize is defined in unistd.h as a static inline
+ # function, which AC_CHECK_FUNCS does not handle properly.
+ ac_cv_func_getpagesize=yes
+ ;;
+
*-*-mingw32*)
# Under mingw32, sys_nerr and sys_errlist exist, but they are
# macros, so the test below won't find them.