summaryrefslogtreecommitdiff
path: root/libiberty/configure.ac
diff options
context:
space:
mode:
authorjakub <jakub@138bc75d-0d04-0410-961f-82ee72b054a4>2014-04-17 12:25:25 +0000
committerTom Tromey <tromey@redhat.com>2014-05-08 10:18:30 -0600
commit3f48575af8379567edcc1d6f7fb25c14237cbf30 (patch)
tree0b16fcde32d18129847a834478611ba629bacf33 /libiberty/configure.ac
parentc3c3c691f2d56953d81a2a7da214623d8aef857c (diff)
downloadbinutils-gdb-3f48575af8379567edcc1d6f7fb25c14237cbf30.tar.gz
PR sanitizer/56781 lto-plugin/ * Makefile.am (CFLAGS, LDFLAGS): Filter out -fsanitize=address. (liblto_plugin_la_LIBADD, liblto_plugin_la_LDFLAGS, liblto_plugin_la_DEPENDENCIES): Prefer ../libiberty/noasan/libiberty.a over ../libiberty/pic/libiberty.a if the former exists. * Makefile.in: Regenerated. libiberty/ * maint-tool: Also emit rule for noasan/ subdirectory. * configure.ac (NOASANFLAG): Set and substitute. * Makefile.in: Regenerated. (NOASANFLAG): Set. (all, $(TARGETLIB), mostlyclean): Handle noasan subdir like pic subdir. (stamp-noasandir): New goal. * configure: Regenerated.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@209476 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.ac')
-rw-r--r--libiberty/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/libiberty/configure.ac b/libiberty/configure.ac
index d6180bcddd9..3380819ab3a 100644
--- a/libiberty/configure.ac
+++ b/libiberty/configure.ac
@@ -236,6 +236,12 @@ if [[ "${shared}" != "yes" ]]; then
fi
AC_SUBST(PICFLAG)
+NOASANFLAG=
+case " ${CFLAGS} " in
+ *\ -fsanitize=address\ *) NOASANFLAG=-fno-sanitize=address ;;
+esac
+AC_SUBST(NOASANFLAG)
+
echo "# Warning: this fragment is automatically generated" > temp-frag
if [[ -n "${frag}" ]] && [[ -f "${frag}" ]]; then