summaryrefslogtreecommitdiff
path: root/ld/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2001-06-27 08:42:29 +0000
committerAlan Modra <amodra@gmail.com>2001-06-27 08:42:29 +0000
commit9f22353f5ba698d6ca4a42697b47f973607c814a (patch)
treebe4f3002e3031784ba0127e4d47217f357f2fa39 /ld/Makefile.am
parentd827344236a4e852e15a74dfd23490c1fc2ac139 (diff)
downloadbinutils-gdb-9f22353f5ba698d6ca4a42697b47f973607c814a.tar.gz
* emulparams/hppa64linux.sh: New file.
* configure.tgt: hppa*64*-*-linux* uses hppa64linux.sh * Makefile.am (ALL_64_EMULATIONS): Add ehppa64linux.o (ehppa64linux.c): Add rule to make it. Run "make dep-am". * Makefile.in: Regenerate.
Diffstat (limited to 'ld/Makefile.am')
-rw-r--r--ld/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/ld/Makefile.am b/ld/Makefile.am
index 27c59634858..b2f04d73227 100644
--- a/ld/Makefile.am
+++ b/ld/Makefile.am
@@ -262,7 +262,8 @@ ALL_64_EMULATIONS = \
eelf64btsmip.o \
eelf64ltsmip.o \
eelf64hppa.o \
- eaixppc64.o
+ eaixppc64.o \
+ ehppa64linux.o
ALL_EMUL_EXTRA_OFILES = \
deffilep.o \
@@ -592,6 +593,9 @@ ehppalinux.c: $(srcdir)/emulparams/hppalinux.sh \
$(srcdir)/emultempl/elf32.em $(srcdir)/emultempl/hppaelf.em \
$(srcdir)/scripttempl/elf.sc ${GEN_DEPENDS}
${GENSCRIPTS} hppalinux "$(tdir_hppalinux)"
+ehppa64linux.c: $(srcdir)/emulparams/hppa64linux.sh \
+ $(srcdir)/emultempl/elf32.em $(srcdir)/scripttempl/elf.sc ${GEN_DEPENDS}
+ ${GENSCRIPTS} hppa64linux "$(tdir_hppa64linux)"
ei386aout.c: $(srcdir)/emulparams/i386aout.sh \
$(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/aout.sc ${GEN_DEPENDS}
${GENSCRIPTS} i386aout "$(tdir_i386aout)"
@@ -1047,7 +1051,7 @@ ldexp.o: ldexp.c ../bfd/bfd.h $(INCDIR)/ansidecl.h \
ldfile.o: ldfile.c ../bfd/bfd.h $(INCDIR)/ansidecl.h \
sysdep.h config.h $(INCDIR)/fopen-same.h $(INCDIR)/bfdlink.h \
ld.h $(INCDIR)/bin-bugs.h ldmisc.h ldexp.h ldlang.h \
- ldfile.h ldmain.h ldgram.h ldlex.h ldemul.h
+ ldfile.h ldmain.h ldgram.h ldlex.h ldemul.h $(INCDIR)/libiberty.h
ldlang.o: ldlang.c ../bfd/bfd.h $(INCDIR)/ansidecl.h \
sysdep.h config.h $(INCDIR)/fopen-same.h $(INCDIR)/libiberty.h \
$(INCDIR)/obstack.h $(INCDIR)/bfdlink.h ld.h $(INCDIR)/bin-bugs.h \
@@ -1095,7 +1099,7 @@ ldgram.o: ldgram.c ../bfd/bfd.h $(INCDIR)/ansidecl.h \
ldlex.h
ldlex.o: ldlex.c ../bfd/bfd.h sysdep.h config.h $(INCDIR)/fopen-same.h \
ld.h $(INCDIR)/bin-bugs.h ldgram.h ldmisc.h ldexp.h \
- ldlang.h ldfile.h ldlex.h ldmain.h
+ ldlang.h ldfile.h ldlex.h ldmain.h $(INCDIR)/libiberty.h
deffilep.o: deffilep.c $(INCDIR)/libiberty.h $(INCDIR)/ansidecl.h \
../bfd/bfd.h sysdep.h config.h $(INCDIR)/fopen-same.h \
ld.h $(INCDIR)/bin-bugs.h ldmisc.h deffile.h