summaryrefslogtreecommitdiff
path: root/ld/Makefile.am
diff options
context:
space:
mode:
authorNick Alcock <nick.alcock@oracle.com>2020-06-11 15:44:48 +0100
committerNick Alcock <nick.alcock@oracle.com>2020-07-22 18:05:32 +0100
commit7cdfc3462fbbb27727ddd83d356cf79af8854740 (patch)
tree8099e7b67ee5dfcf13bcb816a85e87efc0e19c44 /ld/Makefile.am
parentb1b33524ad3c439badba3ce4fa51c0d5a317c4a5 (diff)
downloadbinutils-gdb-7cdfc3462fbbb27727ddd83d356cf79af8854740.tar.gz
ld, testsuite: only run CTF tests when ld and GCC support CTF
The CTF testsuite runs GCC to generate CTF that it knows matches the input .c files before doing a run_dump_test over it. So we need a GCC capable of doing that, and we need to always avoid running those tests if libctf was disabled because the linker will never be capable of it. ld/ * configure.ac (enable_libctf): Substitute it. * Makefile.am (enablings.exp): New. (EXTRA_DEJAGNU_SITE_CONFIG): Add it. (DISTCLEANFILES): Likewise. * Makefile.in: Regenerate. * configure: Likewise. * testsuite/lib/ld-lib.exp (compile_one_cc): New. (check_ctf_available): Likewise. (skip_ctf_tests): Likewise. * testsuite/ld-ctf/ctf.exp: Call skip_ctf_tests.
Diffstat (limited to 'ld/Makefile.am')
-rw-r--r--ld/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/ld/Makefile.am b/ld/Makefile.am
index 38ff2d9bc0a..168f65dfe77 100644
--- a/ld/Makefile.am
+++ b/ld/Makefile.am
@@ -974,6 +974,9 @@ check-DEJAGNU: site.exp
development.exp: $(BFDDIR)/development.sh
$(EGREP) "[development|experimental]=" $(BFDDIR)/development.sh \
| $(AWK) -F= '{ print "set " $$1 " " $$2 }' > $@
+
+enablings.exp:
+ echo "set enable_libctf ${enable_libctf}" >> $@
#
#
# Build a dummy plugin using libtool.
@@ -1020,7 +1023,7 @@ MAINTAINERCLEANFILES = configdoc.texi ld.1
CONFIG_STATUS_DEPENDENCIES = $(srcdir)/configure.host $(srcdir)/configure.tgt \
$(BFDDIR)/development.sh
-EXTRA_DEJAGNU_SITE_CONFIG = development.exp
+EXTRA_DEJAGNU_SITE_CONFIG = development.exp enablings.exp
MOSTLYCLEANFILES = $(STAGESTUFF) ld1$(EXEEXT) ld2$(EXEEXT) ld3$(EXEEXT) \
ldemul-list.h crtbegin.@OBJEXT@ crtend.@OBJEXT@ ld.log ld.sum
@@ -1067,7 +1070,7 @@ diststuff: info $(EXTRA_DIST)
# ld.1 to support parallel build.
info-recursive: ld.1
-DISTCLEANFILES = site.exp development.exp site.bak stringify.sed
+DISTCLEANFILES = site.exp development.exp enablings.exp site.bak stringify.sed
distclean-local:
rm -rf ldscripts