summaryrefslogtreecommitdiff
path: root/gprof/Makefile.am
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-08-22 18:37:50 +0000
committerRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-08-22 18:37:50 +0000
commitfd9b71a87815c4716f77f9c49c6398b3ac078fd2 (patch)
treec206f56a2ba7d4b2e1541df91229cd4283a5c69d /gprof/Makefile.am
parenta5c7551fbec299a0bafd32f0d1ba056703fd52dd (diff)
downloadbinutils-gdb-fd9b71a87815c4716f77f9c49c6398b3ac078fd2.tar.gz
dependency tracking in gprof
gprof/: * Makefile.am (AUTOMAKE_OPTIONS): Remove cygnus, add 1.11, foreign, no-dist, no-texinfo.tex. (TEXINFO_TEX): New variable. (MKDEP, CLEANFILES): Remove: (DEP, DEP1, dep.sed, dep, dep-in, dep-am): Remove rules. (install-data-local): Remove now-unneeded dependency on install-info. (mkdep section): Remove. * Makefile.in: Regenerate.
Diffstat (limited to 'gprof/Makefile.am')
-rw-r--r--gprof/Makefile.am459
1 files changed, 2 insertions, 457 deletions
diff --git a/gprof/Makefile.am b/gprof/Makefile.am
index 6c73106657e..3f41b5133d1 100644
--- a/gprof/Makefile.am
+++ b/gprof/Makefile.am
@@ -1,7 +1,8 @@
## Process this file with automake to generate Makefile.in
-AUTOMAKE_OPTIONS = cygnus
+AUTOMAKE_OPTIONS = 1.11 foreign no-dist no-texinfo.tex
ACLOCAL_AMFLAGS = -I .. -I ../config -I ../bfd
+TEXINFO_TEX = $(top_srcdir)/../texinfo/texinfo.tex
SUFFIXES = .m
@@ -15,8 +16,6 @@ WARN_CFLAGS = @WARN_CFLAGS@
NO_WERROR = @NO_WERROR@
AM_CFLAGS = $(WARN_CFLAGS)
-MKDEP = gcc -MM
-
INCLUDES = -DDEBUG -I../bfd -I$(srcdir)/../include \
-I$(srcdir)/../bfd @INCINTL@ -I. \
-DLOCALEDIR="\"$(datadir)/locale\""
@@ -83,63 +82,6 @@ gprof.1: $(srcdir)/gprof.texi config.texi
(rm -f $@.T$$$$ && exit 1)
rm -f gprof.pod
-# We want install to imply install-info as per GNU standards, despite the
-# cygnus option.
-install-data-local: install-info
-
-# Targets to rebuild dependencies in this Makefile.
-# Have to get rid of DEP1 here so that "$?" later includes all sources.
-DEP: dep.sed $(gprof_SOURCES) $(noinst_HEADERS) gconfig.h
- rm -f DEP1
- $(MAKE) MKDEP="$(MKDEP)" DEP1
- echo '# IF YOU PUT ANYTHING HERE IT WILL GO AWAY' >> DEP1
- if grep ' /' DEP1 > /dev/null 2> /dev/null; then \
- echo 'make DEP failed!'; exit 1; \
- else \
- mv -f DEP1 $@; \
- fi
-
-DEP1: $(gprof_SOURCES)
- echo '# DO NOT DELETE THIS LINE -- mkdep uses it.' > DEP2
- echo '# DO NOT PUT ANYTHING AFTER THIS LINE, IT WILL GO AWAY.' >> DEP2
- for f in $?; do \
- $(MKDEP) $(INCLUDES) $(CFLAGS) $$f > DEPA; \
- sed -n -e '1s/: .*/: \\/p' -e q < DEPA >> DEP2; \
- sed -e '1s/.*: //' -f dep.sed < DEPA | \
- LC_ALL=C sort | LC_ALL=C uniq | \
- sed -e 's/^[AB]/ /' -e '$$s/ \\$$//' >> DEP2; \
- done
- rm -f DEPA
- mv -f DEP2 $@
-
-dep.sed: dep-in.sed config.status
- objdir=`pwd`; \
- sed <$(srcdir)/dep-in.sed >dep.sed \
- -e 's!@INCDIR@!$(INCDIR)!' \
- -e 's!@BFDDIR@!$(BFDDIR)!' \
- -e 's!@SRCDIR@!$(srcdir)!' \
- -e "s!@OBJDIR@!$${objdir}!" \
- -e 's!@TOPDIR@!'`echo $(srcdir) | sed -e s,/gprof$$,,`'!'
-
-dep: DEP
- sed -e '/^..DO NOT DELETE THIS LINE/,$$d' < Makefile > tmp-Makefile
- cat DEP >> tmp-Makefile
- $(SHELL) $(srcdir)/../move-if-change tmp-Makefile Makefile
-
-dep-in: DEP
- sed -e '/^..DO NOT DELETE THIS LINE/,$$d' < $(srcdir)/Makefile.in > tmp-Makefile.in
- cat DEP >> tmp-Makefile.in
- $(SHELL) $(srcdir)/../move-if-change tmp-Makefile.in $(srcdir)/Makefile.in
-
-dep-am: DEP
- sed -e '/^..DO NOT DELETE THIS LINE/,$$d' < $(srcdir)/Makefile.am > tmp-Makefile.am
- cat DEP >> tmp-Makefile.am
- $(SHELL) $(srcdir)/../move-if-change tmp-Makefile.am $(srcdir)/Makefile.am
-
-.PHONY: dep dep-in dep-am
-
-CLEANFILES = dep.sed DEP DEPA DEP1 DEP2
-
MAINTAINERCLEANFILES = gprof.info
# Automake 1.9 will only build info files in the objdir if they are
@@ -148,400 +90,3 @@ MAINTAINERCLEANFILES = gprof.info
if GENINSRC_NEVER
DISTCLEANFILES = gprof.info
endif
-
-# DO NOT DELETE THIS LINE -- mkdep uses it.
-# DO NOT PUT ANYTHING AFTER THIS LINE, IT WILL GO AWAY.
-basic_blocks.o: \
- basic_blocks.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/libiberty.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- basic_blocks.h \
- corefile.h \
- gconfig.h \
- gmon_io.h \
- gmon_out.h \
- gprof.h \
- search_list.h \
- source.h \
- sym_ids.h \
- symtab.h
-call_graph.o: \
- call_graph.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- call_graph.h \
- cg_arcs.h \
- corefile.h \
- gconfig.h \
- gmon_io.h \
- gmon_out.h \
- gprof.h \
- search_list.h \
- source.h \
- sym_ids.h \
- symtab.h
-cg_arcs.o: \
- cg_arcs.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/libiberty.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- call_graph.h \
- cg_arcs.h \
- cg_dfn.h \
- cg_print.h \
- gconfig.h \
- gprof.h \
- search_list.h \
- source.h \
- sym_ids.h \
- symtab.h \
- utils.h
-cg_dfn.o: \
- cg_dfn.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/libiberty.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- cg_arcs.h \
- cg_dfn.h \
- gconfig.h \
- gprof.h \
- search_list.h \
- source.h \
- symtab.h \
- utils.h
-cg_print.o: \
- cg_print.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/libiberty.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- cg_arcs.h \
- cg_print.h \
- corefile.h \
- gconfig.h \
- gprof.h \
- hist.h \
- search_list.h \
- source.h \
- symtab.h \
- utils.h
-corefile.o: \
- corefile.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/libiberty.h \
- $(INCDIR)/safe-ctype.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- corefile.h \
- gconfig.h \
- gprof.h \
- hist.h \
- search_list.h \
- source.h \
- symtab.h
-gmon_io.o: \
- gmon_io.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/binary-io.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/libiberty.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- basic_blocks.h \
- call_graph.h \
- cg_arcs.h \
- corefile.h \
- gconfig.h \
- gmon.h \
- gmon_io.h \
- gmon_out.h \
- gprof.h \
- hertz.h \
- hist.h \
- search_list.h \
- source.h \
- symtab.h
-gprof.o: \
- gprof.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/demangle.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/libiberty.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/bfdver.h \
- ../bfd/config.h \
- basic_blocks.h \
- call_graph.h \
- cg_arcs.h \
- cg_print.h \
- corefile.h \
- gconfig.h \
- gmon_io.h \
- gprof.h \
- hertz.h \
- hist.h \
- search_list.h \
- source.h \
- sym_ids.h \
- symtab.h
-hertz.o: \
- hertz.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- gconfig.h \
- gprof.h \
- hertz.h
-hist.o: \
- hist.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/libiberty.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- corefile.h \
- gconfig.h \
- gmon_io.h \
- gmon_out.h \
- gprof.h \
- hist.h \
- search_list.h \
- source.h \
- sym_ids.h \
- symtab.h \
- utils.h
-source.o: \
- source.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/libiberty.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- gconfig.h \
- gprof.h \
- search_list.h \
- source.h
-search_list.o: \
- search_list.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/libiberty.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- gconfig.h \
- gprof.h \
- search_list.h
-symtab.o: \
- symtab.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- cg_arcs.h \
- corefile.h \
- gconfig.h \
- gprof.h \
- search_list.h \
- source.h \
- symtab.h
-sym_ids.o: \
- sym_ids.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/libiberty.h \
- $(INCDIR)/safe-ctype.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- cg_arcs.h \
- corefile.h \
- gconfig.h \
- gprof.h \
- search_list.h \
- source.h \
- sym_ids.h \
- symtab.h
-utils.o: \
- utils.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/demangle.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/libiberty.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- cg_arcs.h \
- corefile.h \
- gconfig.h \
- gprof.h \
- search_list.h \
- source.h \
- symtab.h \
- utils.h
-i386.o: \
- i386.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- cg_arcs.h \
- corefile.h \
- gconfig.h \
- gprof.h \
- hist.h \
- search_list.h \
- source.h \
- symtab.h
-alpha.o: \
- alpha.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- cg_arcs.h \
- corefile.h \
- gconfig.h \
- gprof.h \
- hist.h \
- search_list.h \
- source.h \
- symtab.h
-vax.o: \
- vax.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- cg_arcs.h \
- corefile.h \
- gconfig.h \
- gprof.h \
- hist.h \
- search_list.h \
- source.h \
- symtab.h
-tahoe.o: \
- tahoe.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- cg_arcs.h \
- corefile.h \
- gconfig.h \
- gprof.h \
- hist.h \
- search_list.h \
- source.h \
- symtab.h
-sparc.o: \
- sparc.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- cg_arcs.h \
- corefile.h \
- gconfig.h \
- gprof.h \
- hist.h \
- search_list.h \
- source.h \
- symtab.h
-mips.o: \
- mips.c \
- $(BFDDIR)/sysdep.h \
- $(INCDIR)/ansidecl.h \
- $(INCDIR)/filenames.h \
- $(INCDIR)/fopen-same.h \
- $(INCDIR)/symcat.h \
- ../bfd/bfd.h \
- ../bfd/config.h \
- cg_arcs.h \
- corefile.h \
- gconfig.h \
- gprof.h \
- hist.h \
- search_list.h \
- source.h \
- symtab.h
-flat_bl.o: \
- flat_bl.c \
- $(INCDIR)/ansidecl.h
-bsd_callg_bl.o: \
- bsd_callg_bl.c \
- $(INCDIR)/ansidecl.h
-fsf_callg_bl.o: \
- fsf_callg_bl.c \
- $(INCDIR)/ansidecl.h
-# IF YOU PUT ANYTHING HERE IT WILL GO AWAY