summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@airs.com>2011-09-23 15:02:32 +0000
committerIan Lance Taylor <ian@airs.com>2011-09-23 15:02:32 +0000
commitdc87f6201460bb5564a94d3c84beb4ab87a9962d (patch)
tree378d39c458b877fe9b42d8db349583a7bc0ad35a /gold/configure.ac
parente04e5beb2e28eb2b84a2667f73908eb1ddc1111c (diff)
downloadbinutils-gdb-dc87f6201460bb5564a94d3c84beb4ab87a9962d.tar.gz
* configure.ac: Add new --with-gold-ldadd and --with-gold-ldflags
configuration options. * configure: Regenerate. * Makefile.am: Handle GOLD_LDADD and GOLD_LDFLAGS. * Makefile.in: Regenerate. * testsuite/Makefile.in: Regenerate.
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index 685e85bbbb0..905dbaf1c70 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -409,6 +409,26 @@ AM_BINUTILS_WARNINGS
WARN_CXXFLAGS=`echo ${WARN_CFLAGS} | sed -e 's/-Wstrict-prototypes//' -e 's/-Wmissing-prototypes//' -e 's/-Wshadow//'`
AC_SUBST(WARN_CXXFLAGS)
+AC_ARG_WITH(gold-ldflags,
+[ --with-gold-ldflags=FLAGS additional link flags for gold],
+[if test "$withval" = "no" -o "$withval" = "yes"; then
+ GOLD_LDFLAGS=
+ else
+ GOLD_LDFLAGS=$withval
+ fi],
+[GOLD_LDFLAGS=])
+AC_SUBST(GOLD_LDFLAGS)
+
+AC_ARG_WITH(gold-ldadd,
+[ --with-gold-ldadd=LIBS additional libraries for gold],
+[if test "$withval" = "no" -o "$withval" = "yes"; then
+ GOLD_LDADD=
+ else
+ GOLD_LDADD=$withval
+ fi],
+[GOLD_LDADD=])
+AC_SUBST(GOLD_LDADD)
+
dnl Force support for large files by default. This may need to be
dnl host dependent. If build == host, we can check getconf LFS_CFLAGS.
LFS_CFLAGS="-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"