summaryrefslogtreecommitdiff
path: root/gnulib/configure.ac
diff options
context:
space:
mode:
authorChristian Biesinger <cbiesinger@google.com>2019-11-14 16:17:59 -0800
committerChristian Biesinger <cbiesinger@google.com>2019-11-15 11:00:39 -0800
commit33bd0102c190c1331804c12774e578e33c367552 (patch)
tree1f1d1fc2c78931f9c50016d16b47149bc2df75e0 /gnulib/configure.ac
parent71d3dc74309599cd9bbdfa17dcfdfd8c406a1093 (diff)
downloadbinutils-gdb-33bd0102c190c1331804c12774e578e33c367552.tar.gz
Generate gnulib's toplevel Makefile.in using automake
This is a lot simpler and as a side-effect this will correctly regenerate import/Makefile and config.h during rebuilds if necessary. gnulib/ChangeLog: 2019-11-15 Christian Biesinger <cbiesinger@google.com> * Makefile.am: New file. * Makefile.in: Replace with generated file. * aclocal-m4-deps.mk: Remove. * configure.ac: Use the foreign option for automake and specify the aclocal search path here. * update-gnulib.sh: Don't generate aclocal-m4-deps.mk anymore. Also don't specify the aclocal include path here, now that it is in configure.ac. Change-Id: I6a2c4d41cf4f0e21d5c813197bad63ed5c08e408
Diffstat (limited to 'gnulib/configure.ac')
-rw-r--r--gnulib/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnulib/configure.ac b/gnulib/configure.ac
index 74e4ae2b688..fac7f6ca85e 100644
--- a/gnulib/configure.ac
+++ b/gnulib/configure.ac
@@ -21,6 +21,8 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT([libgnu], [UNUSED-VERSION])
AC_CONFIG_SRCDIR([import/memmem.c])
AC_CONFIG_HEADER(config.h:config.in)
+AC_CONFIG_MACRO_DIRS([import/m4])
+AC_CONFIG_MACRO_DIRS([../config])
AM_MAINTAINER_MODE
AC_PROG_CC
@@ -37,7 +39,7 @@ gl_INIT
# We don't use automake, but gnulib does. This line lets us generate
# its Makefile.in.
-AM_INIT_AUTOMAKE([no-define])
+AM_INIT_AUTOMAKE([no-define foreign])
AM_SILENT_RULES([yes])