summaryrefslogtreecommitdiff
path: root/gdbsupport/Makefile.am
diff options
context:
space:
mode:
authorTom Tromey <tom@tromey.com>2022-12-16 12:50:29 -0700
committerTom Tromey <tom@tromey.com>2023-02-24 11:53:03 -0700
commit147699fd6991ae67fc22ca543a28f85a242fc930 (patch)
tree6b0db9f0536b143faf89940d3f0e9fa500bd08ae /gdbsupport/Makefile.am
parent1293ecd838c82e86f6c81d4518f5c662f8eaa0b9 (diff)
downloadbinutils-gdb-147699fd6991ae67fc22ca543a28f85a242fc930.tar.gz
Remove struct buffer
I've long wanted to remove 'struct buffer', and thanks to Simon's earlier patch, I was finally able to do so. My feeling has been that gdb already has several decent structures available for growing strings: std::string of course, but also obstack and even objalloc from BFD and dyn-string from libiberty. The previous patches in this series removed all the uses of struct buffer, so this one can remove the code and the remaining #includes.
Diffstat (limited to 'gdbsupport/Makefile.am')
-rw-r--r--gdbsupport/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/gdbsupport/Makefile.am b/gdbsupport/Makefile.am
index 83eb6c35846..00524e9a566 100644
--- a/gdbsupport/Makefile.am
+++ b/gdbsupport/Makefile.am
@@ -42,7 +42,6 @@ endif
libgdbsupport_a_SOURCES = \
agent.cc \
btrace-common.cc \
- buffer.cc \
cleanups.cc \
common-debug.cc \
common-exceptions.cc \