summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorChristopher Faylor <me+cygwin@cgf.cx>1999-02-03 19:29:00 +0000
committerChristopher Faylor <me+cygwin@cgf.cx>1999-02-03 19:29:00 +0000
commitd8f6bd4ee72040373cd06cd0fc2f2b3049d488bd (patch)
treead3ba3eb8eca3cac2cc7c6764be9c270e372814c /gdb/configure.in
parent2a9984fc6532657aedda70993affc106793fb8cb (diff)
downloadbinutils-gdb-d8f6bd4ee72040373cd06cd0fc2f2b3049d488bd.tar.gz
* config/i386/cygwin.mh: Move TERMCAP test code to configure.in.
* configure.in: Treat libtermcap.a detection as a special case when hosting on cygwin. * configure: Regenerate.
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in24
1 files changed, 14 insertions, 10 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 496ff3359ab..4b292c871a0 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -122,16 +122,20 @@ dnl So only link in libw if we have to.
AC_CHECK_LIB(c, wctype,: ,AC_CHECK_LIB(w, wctype))
dnl Figure out which term library to use.
-TERM_LIB=
-AC_CHECK_LIB(ncurses, tgetent, TERM_LIB=-lncurses,
- AC_CHECK_LIB(termlib, tgetent, TERM_LIB=-ltermlib,
- AC_CHECK_LIB(termcap, tgetent, TERM_LIB=-ltermcap,
- AC_CHECK_LIB(curses, tgetent, TERM_LIB=-lcurses,
- AC_CHECK_LIB(terminfo, tgetent, TERM_LIB=-lterminfo)))))
-
-if test "x$TERM_LIB" = x
-then
- AC_MSG_ERROR(Could not find a term library, e.g. termcap or termlib!)
+if test x$gdb_cv_os_cygwin = xyes; then
+ TERM_LIB='`if test -r ../libtermcap/libtermcap.a; then echo ../libtermcap/libtermcap.a; else echo -ltermcap; fi`'
+else
+ TERM_LIB=
+ AC_CHECK_LIB(ncurses, tgetent, TERM_LIB=-lncurses,
+ AC_CHECK_LIB(termlib, tgetent, TERM_LIB=-ltermlib,
+ AC_CHECK_LIB(termcap, tgetent, TERM_LIB=-ltermcap,
+ AC_CHECK_LIB(curses, tgetent, TERM_LIB=-lcurses,
+ AC_CHECK_LIB(terminfo, tgetent, TERM_LIB=-lterminfo)))))
+
+ if test "x$TERM_LIB" = x
+ then
+ AC_MSG_ERROR(Could not find a term library, e.g. termcap or termlib!)
+ fi
fi
AC_SUBST(TERM_LIB)