summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorAndrew Cagney <cagney@redhat.com>2000-03-03 05:44:39 +0000
committerAndrew Cagney <cagney@redhat.com>2000-03-03 05:44:39 +0000
commitb3a903328130b25f4882151159ae66b38e397b41 (patch)
tree87906f48beb7fa713862708d8db20a31abca4571 /gdb/configure.in
parent379d643457e5153e55698eb6e0cac2773077ae2b (diff)
downloadbinutils-gdb-b3a903328130b25f4882151159ae66b38e397b41.tar.gz
Move GDBtk's ``ln -s ... gdbtcl'' code out of configure.
Add CONFIG_CLEAN, CONFIG_ALL to configured targets. Add all-gdbtk, clean-gdbtk.
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in18
1 files changed, 8 insertions, 10 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index c12bdae22a1..ec4ac637c02 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -43,6 +43,8 @@ CONFIG_DEPS=
CONFIG_SRCS=
CONFIG_INITS=
ENABLE_CFLAGS=
+CONFIG_ALL=
+CONFIG_CLEAN=
CONFIG_INSTALL=
CONFIG_UNINSTALL=
@@ -390,6 +392,8 @@ case ${enable_gdbmi} in
CONFIG_SRCS="${CONFIG_SRS} \$(SUBDIR_MI_SRCS)"
CONFIG_INITS="${CONFIG_INITS} \$(SUBDIR_MI_INITS)"
ENABLE_CFLAGS="${ENABLE_CFLAGS} \$(SUBDIR_MI_CFLAGS)"
+ CONFIG_ALL="${CONFIG_ALL} \$(SUBDIR_MI_ALL)"
+ CONFIG_CLEAN="${CONFIG_CLEAN} \$(SUBDIR_MI_CLEAN)"
CONFIG_INSTALL="${CONFIG_INSTALL} \$(SUBDIR_MI_INSTALL)"
CONFIG_UNINSTALL="${CONFIG_UNINSTALL} \$(SUBDIR_MI_UNINSTALL)"
fi
@@ -701,6 +705,8 @@ if test "${enable_gdbtk}" = "yes"; then
CONFIG_SRCS="${CONFIG_SRCS} gdbtk/generic/gdbtk.c gdbtk/generic/gdbtk-cmds.c gdbtk/generic/gdbtk-hooks.c gdbtk/generic/gdbtk-varobj.c gdbtk/generic/gdbtk-wrapper.c"
CONFIG_OBS="${CONFIG_OBS} gdbtk.o gdbtk-cmds.o gdbtk-hooks.o gdbtk-varobj.o gdbtk-wrapper.o"
CONFIG_INITS="${CONFIG_INITS} gdbtk/generic/gdbtk.c gdbtk/generic/gdbtk-cmds.c gdbtk/generic/gdbtk-hooks.c gdbtk/generic/gdbtk-varobj.c gdbtk/generic/gdbtk-wrapper.c"
+ CONFIG_ALL="${CONFIG_ALL} \$(SUBDIR_GDBTK_ALL)"
+ CONFIG_CLEAN="${CONFIG_ALL} \$(SUBDIR_GDBTK_CLEAN)"
CONFIG_INSTALL="${CONFIG_INSTALL} \$(SUBDIR_GDBTK_INSTALL)"
CONFIG_UNINSTALL="${CONFIG_UNINSTALL} \$(SUBDIR_GDBTK_UNINSTALL)"
@@ -767,6 +773,8 @@ AC_SUBST(CONFIG_OBS)
AC_SUBST(CONFIG_DEPS)
AC_SUBST(CONFIG_SRCS)
AC_SUBST(CONFIG_INITS)
+AC_SUBST(CONFIG_ALL)
+AC_SUBST(CONFIG_CLEAN)
AC_SUBST(CONFIG_INSTALL)
AC_SUBST(CONFIG_UNINSTALL)
@@ -912,16 +920,6 @@ files="${files} config/nm-empty.h"
links="${links} nm.h"
fi
AC_PROG_LN_S
-# Make it possible to use the GUI without doing a full install
-if test "${enable_gdbtk}" = "yes" ; then
- if test "$LN_S" = "ln -s" -a ! -f gdbtcl ; then
- echo linking $srcdir/gdbtk/library to gdbtcl
- $LN_S $srcdir/gdbtk/library gdbtcl
- else
- echo Warning: Unable to link $srcdir/gdbtk/library to gdbtcl. You will need to do a
- echo " " make install before you are able to run the GUI.
- fi
-fi
AC_LINK_FILES($files, $links)