summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorDoug Evans <xdje42@gmail.com>2014-09-09 21:18:25 -0700
committerDoug Evans <xdje42@gmail.com>2014-09-09 21:18:25 -0700
commitd342a0da4fa83b680426511a7d0e1b1e299c63b8 (patch)
tree8d2b73afdc502bb218f675735c82961b5e407c78 /gdb/configure.ac
parentb4a3d263b07508de083928823aee72699e59afc0 (diff)
downloadbinutils-gdb-d342a0da4fa83b680426511a7d0e1b1e299c63b8.tar.gz
PR guile/17367
gdb/ChangeLog: * acinclude.m4 (GDB_GUILE_PROGRAM_NAMES): Pass guile version as last parameter to pkg-config, not first. * configure.ac: Pass --with-guile provided pkg-config path to GDB_GUILE_PROGRAM_NAMES. * configure: Regenerate.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac14
1 files changed, 11 insertions, 3 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index ab7b1c2c270..4f5fb7bf28f 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1143,8 +1143,9 @@ dnl It could be a shell script. It is invoked as:
dnl pkg-config --exists $version
dnl pkg-config --cflags $version
dnl pkg-config --libs $version
-dnl $version will be the default guile version (currently guile-2.0),
-dnl but the program is free to ignore this.
+dnl pkg-config --variable guild $version
+dnl The script will be called with $version having each value in
+dnl $try_guile_versions until --exists indicates success.
AC_ARG_WITH(guile,
AS_HELP_STRING([--with-guile@<:@=GUILE@:>@], [include guile support (auto/yes/no/<guile-version>/<pkg-config-program>)]),
@@ -1196,7 +1197,14 @@ esac
if test "${have_libguile}" != no; then
dnl Get the name of the 'guild' program.
- GDB_GUILE_PROGRAM_NAMES(["${pkg_config_prog_path}"], ["${guile_version}"])
+ case "${with_guile}" in
+ [[\\/]]* | ?:[[\\/]]*)
+ GDB_GUILE_PROGRAM_NAMES(["${with_guile}"], ["${guile_version}"])
+ ;;
+ *)
+ GDB_GUILE_PROGRAM_NAMES(["${pkg_config_prog_path}"], ["${guile_version}"])
+ ;;
+ esac
dnl Make sure guild can handle this host.
GDB_TRY_GUILD([$srcdir/guile/lib/gdb/support.scm])