summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorYao Qi <yao@codesourcery.com>2014-11-04 22:17:02 +0800
committerYao Qi <yao@codesourcery.com>2014-11-28 18:37:52 +0800
commitbdca27a2f57f5152ec83766d7a8b25b2d33b8905 (patch)
treeef9071bec4fb43dbce216e92fee033b7754e7dda /gdb/configure.ac
parent2196f55f0140f3e278ed4002040f32acc5a6aaf1 (diff)
downloadbinutils-gdb-bdca27a2f57f5152ec83766d7a8b25b2d33b8905.tar.gz
Use readlink unconditionally
Since readlink module is imported, we can use it unconditionally. This patch is to remove configure checks and HAVE_READLINK checks in code. It was mentioned in the patch below [RFA/commit] gdbserver: return ENOSYS if readlink not supported. https://sourceware.org/ml/gdb-patches/2012-02/msg00148.html to use readlink in gdbserver, but we chose something simple at that moment. gdb: 2014-11-28 Yao Qi <yao@codesourcery.com> * configure.ac (AC_CHECK_FUNCS): Remove readlink. * config.in, configure: Re-generate. * inf-child.c (inf_child_fileio_readlink): Don't check HAVE_READLINK is defined. gdb/gdbserver: 2014-11-28 Yao Qi <yao@codesourcery.com> * configure.ac(AC_CHECK_FUNCS): Remove readlink. * config.in, configure: Re-generate. * hostio.c (handle_unlink): Remove code checking HAVE_READLINK is defined.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 98eb57b5b53..bcf1ef2ea9b 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1305,7 +1305,7 @@ AC_C_BIGENDIAN
AC_FUNC_MMAP
AC_FUNC_VFORK
AC_CHECK_FUNCS([canonicalize_file_name realpath getrusage getuid getgid \
- pipe poll pread pread64 pwrite readlink resize_term \
+ pipe poll pread pread64 pwrite resize_term \
sbrk setpgid setpgrp setsid \
sigaction sigprocmask sigsetmask socketpair \
ttrace wborder wresize setlocale iconvlist libiconvlist btowc \